poj 1575 Easier Done Than Said?

Easier Done Than Said?
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4792 Accepted: 2670

Description

Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember. 

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules: 

It must contain at least one vowel. 

It cannot contain three consecutive vowels or three consecutive consonants. 

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'. 

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable. 

Input

The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

Output

For each password, output whether or not it is acceptable, using the precise format shown in the example.

Sample Input

a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end

Sample Output

<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.

Source

Mid-Central USA 2000


题目并不难,题意也非常清晰,是一道水题,但是就像很多时候一样(我以前也这样),许多人喜欢把代码写得“花哨”,展现自己的奇思妙想。这样做,如果能解决问题固然好,但是如果自己能力不足,思维不够缜密,想出的奇思妙想(算法)存在漏洞,那之后的debug也是一件劳心的差事,更为糟糕的是,由于自己不走寻常路,加上代码花哨,拿出手的代码别人也很难读下去,可读性极差,这样的代码往往是可悲的,我以前也喜欢那样,满足自己对自我的肯定,但是现在应该更注重代码的可读性——代码之美的一个重要保障,所以,对于代码的可读性,这里有几点注意的地方:

1.变量的命名,函数的命名

a,b,c,i,j,k这些无意义的代号,在变量名较少的时候挺适用的,但是一旦变量名多起来之后,26个小写字母的变量名就显得很难理解其含义了,所以说还是谭老那句话“见名知意”的变量命名法是十分合适的,虽然不应用整个英语单词,但是取其具有区分度的开头几个字母还是可取的,这对于函数名来说,亦是如此。

2.模块化编程,面向过程编程

模块化的体现:函数化(同一功能的重复使用)

面向过程:“过程”——从上一步到下一步


//Code:
#include<iostream>
#include<cstdio>
#include<string>
#include<set>
using namespace std;

set<char> vow,cons;     //vow来自vowels“元音”
                        //cons来自consonants“辅音”
bool qua1(string a)    //qua来自单词qualification “条件,合格”
{
    for(int i=0; i<a.length(); i++)
        if(vow.count(a.at(i)))
            return true;
    return false;
}

bool qua2(string a)
{
    for(int i=0; i<a.length(); i++)
    {
        bool flag1,flag2;
        if(i+2<a.length())
        {
            flag1=vow.count(a.at(i))&&vow.count(a.at(i+1))&&vow.count(a.at(i+2));
            flag2=cons.count(a.at(i))&&cons.count(a.at(i+1))&&cons.count(a.at(i+2));
            if(flag1||flag2) return false;
        }
    }
    return true;
}

bool qua3(string a)
{
    for(int i=0; i<a.length()-1; i++)
    {
        if(a.at(i)!='e'&&a.at(i)!='o')
        {
            if(a.at(i+1)==a.at(i))
                return false;
        }
    }
    return true;
}

int main()
{
    //freopen("in.txt","r",stdin);
    for(char i='a'; i<='z'; i++)
    {
        if(i=='a'||i=='e'||i=='i'||i=='o'||i=='u')
            vow.insert(i);
        else cons.insert(i);
    }
    string let;   //来自题目中的letter
    while(cin>>let,let!="end")
    {
        cout<<"<"<<let<<">";
        if(qua1(let)&&qua2(let)&&qua3(let))
            printf(" is acceptable.\n");
        else
            printf(" is not acceptable.\n");
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值