1.六一献礼
问题描述
六月的阳光热情似火,孩子们的笑声洋溢着快乐。六一儿童节,是属于每一位孩子的节日。
快乐成长,梦想起航。正是无数孩子的天真无邪,才有了我们五彩斑斓的世界。
现在,为了庆祝这个属于孩子们的节日,蓝桥云课特别准备了一份礼物,希望能够带给每一位孩子、参赛者惊喜和欢乐。
请你输出 61,领取这份礼物!
签到题,直接输出61
public class Main {
public static void main(String[] args) {
System.out.println(61);
}
}
2.六一晚餐
问题描述
随着六一儿童节的临近,蓝桥学院的校长决定组织所有班级的学生外出共享一顿丰盛的晚餐以庆祝这一特别的日子。餐厅已经准备好了n 张餐桌,每个班级将占用一张餐桌。为了让大家坐得舒适,他们需要为每张桌子添加x把椅子。
餐厅有m种颜色的椅子供选择,其中第i中颜色的椅子有ai把。因为每个班级都有x名学生,所以每张桌子都需要配备x把椅子。
为了让餐厅的氛围更加和谐美好,校长提出了以下两个要求:
1.每张桌子的所有椅子必须是同一种颜色。
2.每种颜色的椅子至少要被用在一张桌子上。
现在,请你帮助校长判断能否在满足上述条件的情况下安排好椅子。
输入格式
第一行包含一个整数T(1<=T<=10^2),表示数据组数。
对于每组数据:
第一行包含三个整数n,m,x(1<=n,m,x<=10^3),分别表示餐桌数量、椅子颜色数量和每张桌子需要的椅子数量。
第二行包含m个整数a1,a2,…,am (1<=ai<= 10^3),表示每种颜色的椅子数量。
输出格式
对于每组数据,如果能够满足校长的要求,输出 Yes,否则输出 No。
样例输入
2
2 2 2
1 4
3 3 4
5 5 5
样例输出
No
Yes
开始没想到如果某种颜色的椅子小于每张桌子需要的椅子数量直接为不满足,一直是30%的通过率。
import java.util.*;
public class Main {
public static void main(String[] args) throws Exception {
Scanner scan = new Scanner(System.in);
int t = scan.nextInt();
while (t-- > 0) {
int n = scan.nextInt();//餐桌数量
int m = scan.nextInt();//椅子颜色数量
int x = scan.nextInt();//每张桌子需要的椅子数量
int[] a = new int[m];
for (int i = 0; i < m; i++) a[i] = scan.nextInt();
int sum = 0;
boolean flag = true;
for (int i = 0; i < m; i++) {
if (a[i] < x) {
flag = false;
break;
}
else sum += a[i] / x;
}
if (flag && sum >= n && n >= m) System.out.println("Yes");
else System.out.println("No");
}
}
}
3.字符串连接计数
问题描述
给定N个字符串S1,S2,⋯,SN,请计算任选其中两个不同的字符串Si,Sj,并按照Si,Sj的顺序连接所形成的字符串T共有多少种不同的结果。
输入格式
输入包含多行,第一行为一个整数N(2<=N<=100),表示字符串的数量。
接下来的N行,每行为一个字符串 Si(1<=∣Si∣<=100),由英文小写字母组成。
输出格式
输出一个整数,表示不同结果的数量。
样例输入
3
abc
def
ghi
样例输出
6
通过Set集合来去重
import java.util.*;
public class Main {
public static void main(String[] args) {
Set<String> set = new HashSet<>();
Scanner scan = new Scanner(System.in);
int n = scan.nextInt();
String[] str = new String[n];
for (int i = 0; i < n; i++) str[i] = scan.next();
for (int i = 0; i < n; i++) {
for (int j = i+1; j < n; j++) {
set.add(str[i]+str[j]);
set.add(str[j]+str[i]);
}
}
System.out.println(set.size());
}
}
4.字符串加法
问题描述
字符串王国也是存在加减乘除计算法则的,只不过与我们熟悉的法则有所不同。
以加法为例:两个数字13和14,按照正常加法来说结果为27。但在字符串王国的加法中,它们相加的结果为1314,即直接将两个数字进行拼接。
现在,给定两个数字A和B,请你按照字符串王国的加法法则计算A+B的结果。
请注意答案可能很大,你需要将答案对10^9+7进行取模后再输出。
输入格式
第一行输入一个数字A(1<=A<=10^100000)。
第二行输入一个整数B(1<=B<=10^100000)。
保证A,B为合法数字。
输出格式
输出一个整数表示答案。
输入样例
12345
54321
输出样例
234554314
看到数据范围果断选择字符串+大数BigInteger,快读快写可以换成正常的Scanner
import java.io.*;
import java.math.BigInteger;
public class Main {
static PrintWriter pw = new PrintWriter(new BufferedWriter(new OutputStreamWriter(System.out)));
static StreamTokenizer st = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
static BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
public static void main(String[] args) throws Exception{
String str1 = Line();
String str2 = Line();
String str3 = str1+str2;
BigInteger big = new BigInteger(str3);
int mod = (int)1e9+7;
BigInteger bb = new BigInteger("1000000007");
BigInteger b = big.remainder(bb);
pw.println(b);
pw.flush();
}
public static String Line() throws Exception{
String s = bf.readLine();
return s;
}
}