hdu1010搜索+剪枝

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42078    Accepted Submission(s): 11382


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
 
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
 
  
NO YES
 
这题要解释一下,剪枝剪出翔了。奇偶剪枝以前都没听说过。反正要各种注意,
DFS用回溯法框架来做
#include <iostream>
#include <cmath>
using namespace std;
int N,M,T;

int time_used;

char map[7][7];
int dirx[4]={-1,0,1,0};
int diry[4]={0,1,0,-1};
int sx,sy;
int ex,ey;
bool flag;
int Count;

void DFS(int x,int y)
{
     int xx,yy;
     if(flag)
         return;
     if((x == ex && y == ey)&& (time_used == T))    //达到条件退出 
     {
         flag = true;
         return;
     }
     if((T-time_used)%2 != (abs(x-ex)+abs(y-ey))%2)  //奇偶减枝法
         return;
     if(abs(x-ex)+abs(y-ey) > T-time_used)  
                           //当前点到终点的最短时间若比剩余的时间还长的话
         return;
     

     
     for(int i = 0; i < 4;i++)      //向四个方向扩展 
     {
         xx = x + dirx[i];
         yy = y + diry[i];
         if( (xx >= 0) && (xx < N) && (yy >= 0) && (yy <M) && map[xx][yy] != 'X')
         {
                  
                  map[x][y] = 'X';
                  time_used++;
                  DFS(xx,yy);
                  time_used--;       
                  map[x][y] = '.';
                  
         }
     }
}




int main()
{
    
    while(cin>>N>>M>>T)
    {
       if(!N && !M && !T)
             break;
       Count = 0;
       for(int i = 0;i < N;i++)
       {
            for(int j = 0;j < M;j++)
            {
                cin>>map[i][j];
                if(map[i][j] == 'S')
                {
                    sx = i;
                    sy = j;
                }
                if(map[i][j] == 'D')
                {
                    ex = i;
                    ey = j;
                }
                else if(map[i][j] == '.')
                {
                     Count++;
                }
            }
            
       }
       if(Count +1 < T)      // 如果总共可以走的步数比给定时间少 
       {
           cout<<"NO"<<endl;
           continue;
       }
       time_used = 0;
       flag = false;
       DFS(sx,sy);
       if(flag == true)
           cout<<"YES"<<endl;
       else
           cout<<"NO"<<endl;
       
    }
    return 0;
}

扩展:

奇偶剪枝

  是数据结构的搜索中,剪枝的一种特殊小技巧。   现假设起点为(sx,sy),终点为(ex,ey),给定t步恰好走到终点,   
s
|
|
|
+ e
如图所示(“|”竖走,“—”横走,“+”转弯),易证abs(ex-sx)+abs(ey-sy)为此问题类中任意情况下,起点到终点的最短步数,记做step,此处step1=8;   
s
+
| +
|
+ e
如图,为一般情况下非 最短路径的任意走法举例,step2=14;   step2-step1=6,偏移路径为6,偶数(易证);   故,若t-[abs(ex-sx)+abs(ey-sy)]结果为非偶数(奇数),则无法在t步恰好到达;   返回,false;    反之亦反。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值