数据结构实验之查找二:平衡二叉树

Problem Description

根据给定的输入序列建立一棵平衡二叉树,求出建立的平衡二叉树的树根。

Input

输入一组测试数据。数据的第1行给出一个正整数N(n <= 20),N表示输入序列的元素个数;第2行给出N个正整数,按数据给定顺序建立平衡二叉树。

Output

输出平衡二叉树的树根。

Example Input
5
88 70 61 96 120
Example Output
70

Hint

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct hh
{
    int data;
    int d;
    struct hh *l;
    struct hh *r;
};
int deep(struct hh *p)
{
    if(p==NULL)
        return -1;
    else
        return p->d;
}
int max(int x,int y)
{
    if(x>y)
        return x;
    return y;
}
struct hh *LL(struct hh *p)
{
    struct hh *q=p->l;
    p->l=q->r;
    q->r=p;
    q->d=max(deep(q->l),deep(q->r))+1;
    p->d=max(deep(p->l),deep(p->r))+1;
    return q;
}
struct hh *RR(struct hh *p)
{
    struct hh *q=p->r;
    p->r=q->l;
    q->l=p;
    q->d=max(deep(q->l),deep(q->r))+1;
    p->d=max(deep(p->l),deep(p->r))+1;
    return q;
}
struct hh *LR(struct hh *p)
{
    p->l=RR(p->l);
    return LL(p);
}
struct hh *RL(struct hh *p)
{
    p->r=LL(p->r);
    return RR(p);
}
struct hh *creat(struct hh *p,int x)//创建平衡二叉树的具体算法
{
    if(p==NULL)
    {
        p=(struct hh *)malloc(sizeof(struct hh));
        p->l=NULL;
        p->r=NULL;
        p->data=x;
        p->d=0;
    }
    else if(x<p->data)
    {
        p->l=creat(p->l,x);
        if(deep(p->l)-deep(p->r)>1)
        {
            if(x<p->l->data)
                p=LL(p);
            else
                p=LR(p);
        }
    }
    else if(x>p->data)
    {
        p->r=creat(p->r,x);
        if(deep(p->r)-deep(p->l)>1)
        {
            if(x>p->r->data)
                p=RR(p);
            else
                p=RL(p);
        }
    }
    p->d=max(deep(p->l),deep(p->r))+1;
    return p;
}
int main()
{
    struct hh *p=NULL;
    int n,i,x;
    scanf("%d",&n);
    for(i=0;i<n;i++)//创建平衡二叉树
    {
        scanf("%d",&x);
        p=creat(p,x);
    }
    printf("%d\n",p->data);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值