数据结构实验之查找三:树的种类统计

Problem Description

随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。

Input

输入一组测试数据。数据的第1行给出一个正整数N (n <= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。

Output

按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。

Example Input
2
This is an Appletree
this is an appletree
Example Output
this is an appletree 100.00%
Hint
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct hh
{
    char data[30];
    int num;
    struct hh *l,*r;
};
char a[30];
int n;
struct hh *creat(struct hh *p)
{
    if(p==NULL)
    {
        p=(struct hh *)malloc(sizeof(struct hh));
        p->l=NULL;
        p->r=NULL;
        p->num=1;
        strcpy(p->data,a);
    }
    else
    {
        if(strcmp(a,p->data)==0)
            p->num++;
        else if(strcmp(a,p->data)<0)
            p->l=creat(p->l);
        else
            p->r=creat(p->r);
    }
    return p;
}
void in(struct hh *p)
{
    if(p!=NULL)
    {
        in(p->l);
        printf("%s %.2lf%%\n",p->data,1.0*p->num*100/n);
        in(p->r);
    }
}
int main()
{
    int i,j,m;
    struct hh *root;
    scanf("%d\n",&n);
    root=NULL;
    for(i=0;i<n;i++)
    {
        gets(a);
        m=strlen(a);
        for(j=0;j<m;j++)
            a[j]=tolower(a[j]);
        root=creat(root);
    }
    in(root);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值