3005

3005

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.<br><br>The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. <br><br>They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. <br><br>Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.<br>
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,<br>representing the number of different blocks in the following data set. The maximum value for n is 30.<br>Each of the next n lines contains three integers representing the values xi, yi and zi.<br>Input is terminated by a value of zero (0) for n.<br>
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".<br>
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 
题意:
有 t 组数字,每组三个数,做为一类长方体的,长,宽,高,由于高可以是三个数字中的任意一个,所以每三个数字一般能代表3种不同类型的长方体
假设每种长方体有无限多个,问以垒积木的方式(上方的积木必须严格小于下方的积木),最多可以垒多高
思路:
用dp来解,先按照如果长相等宽大的放在前面,如果不等,按长由大到小排序.由于里面存在如 (9,1) (7,8)这样的对,而且不能保证这一段序列都是如题意所述,严格单调递减的,所以不能用贪心去解答.递推式:在编号为i,j的两个长方体严格单调递减的情况下,dp[i]=max(dp[j]+h,dp[i]).
AC代码:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct node{
 int x;
 int y;
 int z;
 int area;
}b[40];
int cmp(const void *a,const void *b)
{
 struct node *c,*d;
 c=(struct node*)a;
 d=(struct node*)b;
 return c->area-d->area;
}
int cheak(node a,node b)
{
 if((a.x<b.x&&a.y<b.y)||(a.y<b.x&&a.x<b.y))
  return 1;
 else
  return 0;
}
int main()
{
 int sum[200];
 int dir[3][3]={{0,1,2},{0,2,1},{1,2,0}};
 int n,a[3],count=0,num,i,j;
 while(scanf("%d",&n),n!=0)
 {
  num=0;
  memset(sum,0,sizeof(sum));
  for( i=0;i<n;i++)
  {
   scanf("%d%d%d",&a[0],&a[1],&a[2]);
   for( j=0;j<3;j++)
   {
    b[num].x=a[dir[j][0]];
    b[num].y=a[dir[j][1]];
    b[num].z=a[dir[j][2]];
    b[num].area=b[num].x*b[num].y;
    num++;
   }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值