3024

3024

Problem X

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 24   Accepted Submission(s) : 16
Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.<br>The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.<br>If he had M units of money, what’s the maximum value iSea could get?<br><br>
 

Input
There are several test cases in the input.<br><br>Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.<br>Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.<br><br>The input terminates by end of file marker.<br><br>
 

Output
For each test case, output one integer, indicating maximum value iSea could get.<br><br>
 

Sample Input
  
  
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
  
  
5 11
 

题意:有N件商品,每件商品的价值为PI,每件商品在你的钱大于等于QI时才可以买入,每件商品在你心中都有价值vI.假设你有M元钱,怎么购买才能使得买到的商品的总价值最大;

思路:0-1背包问题;M元钱可以类比成书包拍的总容量。在容量固定的情况下考虑价值;

          对于每件商品只有两种情况,买或者不买;

          买了第N件商品:f(n,m)=f(n-1,m-pn)+v[n];减小了问题的规模

          没买第N件商品:f(n,m)=f(n-1,m);

         按q-p由小到大排序,然后就可以不再考虑顺序问题了;

AC代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;


struct node
{
    int p,q,v;
} a[555];


int cmp(node x,node y)//按q-p排序,保证差额最小为最优
{
    return x.q-x.p<y.q-y.p;
}


int main()
{
    int n,m,i,j;
    int dp[5555];
    while(~scanf("%d%d",&n,&m))
    {
        for(i = 0; i<n; i++)
            scanf("%d%d%d",&a[i].p,&a[i].q,&a[i].v);
        memset(dp,0,sizeof(dp));
        sort(a,a+n,cmp);
        for(i = 0; i<n; i++)
        {
            for(j = m; j>=a[i].q; j--)//剩余的钱大于q才能买
            {
                dp[j] = max(dp[j],dp[j-a[i].p]+a[i].v);//这里的j-a[i].p决定了之前的排序方法
            }
        }
        printf("%d\n",dp[m]);
    }


    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值