Rightmost Digit

Description

Given a positive integer N, you should output the most right digit of N^N. 
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case contains a single positive integer N(1<=N<=1,000,000,000). 
 

Output

For each test case, you should output the rightmost digit of N^N. 
 

Sample Input

    
    
2 3 4
 

Sample Output

    
    
7 6

Hint

 In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6. 

求n的n次方的个位数 只取n个位的n次方 999的999次方可化为9的999次方 其他的看代码就能懂 不会特别的方法 只是最普通的方法

<pre name="code" class="cpp">#include<cstdio>
int wei(__int64 p)
{
	 return p%10;
}
int wei2(__int64 q)
{
	return q%100;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		__int64 n;
	scanf("%I64d",&n);
	 int m=wei(n);//取个位
	 int k=wei2(n); //取后两位数   
           int yu=k%4;//一个数的后两位是4的倍数这个数就是4的倍数
	  int sum=1;
	   //一共分为3种情况
	 if(m==0||m==1||m==5||m==6|m==9)
	 {
	 	 printf("%d\n",m); 
	 }
	    
     else
     {
     	  if(m==4)
     	  {
     	  	 printf("6\n");
		   }
	    
	     else //剩下的这种情况全部为4个数循环  例如3(3 9 7 1 3) 7(7 9 3 1 7)
	     {
	     	if(yu==0)
	     	{
	     		printf("%d\n",m*m*m*m%10);
			 }
			 else
			 {
			 	for(int i=1;i<=yu;i++)
	          {
	    	   sum=sum*m;
		     }
		      printf("%d\n",sum%10);
			 }
	     	 
		 }
	  
	 }
	   
	}
	
	return 0;
}




 
  
 
  
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值