安装CocoaPods时报错 [!] The dependency `AFNetworking (~> 3.0.3)` is not used in any concrete target.

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/KingOfOnePiece/article/details/80689365

问题:

安装CocoaPods时报错

[!] The dependency `AFNetworking (~> 3.0.3)` is not used in any concrete target.


解决方案:

在创建Podfile时,使用这种格式:


platform :ios, '8.0'

#use_frameworks!个别需要用到它,比如reactiveCocoa

target 'TestPod' do

  pod 'AFNetworking', '~> 2.6'

  pod 'ORStackView', '~> 3.0'

  pod 'SwiftyJSON', '~> 2.3'

end

里面的“TestPod”名称需要修改为自己工程的Target。

这么操作基本OK,执行pod install / pod update就可以正常安装pod了。


另一种写法:

platform :ios, '8.0'

#use_frameworks!个别需要用到它,比如reactiveCocoa


def pods

  pod 'AFNetworking', '~> 2.6'

  pod 'ORStackView', '~> 3.0'

  pod 'SwiftyJSON', '~> 2.3'

end

target 'TestPod' do

  pods

end


资料网站:

pingan.wiki

onlyo.cn



没有更多推荐了,返回首页

私密
私密原因:
请选择设置私密原因
  • 广告
  • 抄袭
  • 版权
  • 政治
  • 色情
  • 无意义
  • 其他
其他原因:
120
出错啦
系统繁忙,请稍后再试