【poj】lca模板题 poj1330

Time Limit: 1000MS Memory Limit: 10000KB 64bit IO Format: %I64d & %I64u

 Status

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below: 


In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is. 

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y. 

Write a program that finds the nearest common ancestor of two distinct nodes in a tree. 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3


才学了lca,于是找了一些lca的模板题来练练手,写的是在线算法,倍增lca。。具体看代码注释吧

【代码】:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct edge{
	int u,v,next;
}e[10000 + 10];
int head[10000 + 10],k = 1;
int deep[10000 + 5];
int vis[10000 + 5];
int p[10000][20 + 5];//p[i][j]表示第i点的第2^j个祖先
int T;
int n;
void adde(int u,int v)
{
	e[k].u = u;
	e[k].v = v;
	e[k].next = head[u];
	head[u] = k++;
}
void dfs(int u)
{
	for(int i = head[u]; i ; i = e[i].next)
	{
		if(!deep[e[i].v])
		{
			deep[e[i].v] = deep[u] + 1;
			p[e[i].v][0] = u;
			dfs(e[i].v);
		}
	}
}
void init()
{
	int i, j;
	for(j = 1; (1 << j) <= n; j++)
	{
		for(i = 1; i <= n; i++)
		{
			//if(p[i][j - 1] != -1)
			p[i][j] = p[p[i][j - 1]][j - 1];//i的第2^j-1的祖先的第2^j-1的祖先就是i的第2^j个祖先,有点绕,可画图看
		}
	}
}
int lca(int a,int b)
{
	int i, j;
	if(deep[a] < deep[b])swap(a,b);
	for(i = 0; (1 << i) <= n; i++);
	i--;//找出最多跳的次数
	for(j = i; j >= 0; j--)
	if(deep[a] - (1 << j) >= deep[b])
	a = p[a][j];//跳到与b同一深度
	if(a == b)return a;//此情况是a,b同点
	for(j = i; j >= 0; j--)
	{
		if(p[a][j] != -1 && p[a][j] != p[b][j])//a,b的最远的不相等的祖先的父亲就是求得lca
		{
			a = p[a][j];
			b = p[b][j];//不断向上跳
		}
	}
	return p[a][0];//最后a的父亲便是lca
}
int main()
{
	scanf("%d",&T);
	while(T--)
	{
		int root;
		memset(p,0,sizeof(p));
		memset(deep,0,sizeof(deep));
		memset(head,0,sizeof(head));
		memset(vis,0,sizeof(vis));
		//memset(e,0,sizeof(e));
		k = 1;
		scanf("%d",&n);
		for(int i = 1; i < n; i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			p[b][0] = a;
			adde(a,b);
			if(p[a][0] == 0)
			root = a;
		}
		deep[root] = 1;
		dfs(root);
		init();
		int x,y;
		scanf("%d%d",&x,&y);
		printf("%d\n",lca(x,y));
	}
	
	
	return 0;
}
最后想说的是,为什么会超时,似乎有点问题。。到时等理解更深后在来优化吧,代码没问题。就当做模板吧

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值