POJ2386 Lake Counting【DFS】

题目链接:POJ2386 Lake Counting

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 55916 Accepted: 27265

Description
Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John’s field, determine how many ponds he has.

Input
Line 1: Two space-separated integers: N and M
Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output
Line 1: The number of ponds in Farmer John’s field.

Sample Input
10 12
W…WW.
.WWW…WWW
…WW…WW.
…WW.
…W…
…W…W…
.W.W…WW.
W.W.W…W.
.W.W…W.
…W…W.

Sample Output
3

Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.

程序说明:

深度优先搜索,搜索到某点时将该点用’ . '代替,然后对该点的邻接点搜索。
注意数组下标从1开始,判断的条件都是 == ’ W '。(要特别注意如果判断条件是 != ’ . ’ ,则可能会搜索到0下标的数组空间)
注意判断是否在园子里的条件是nx <= n,而不是nx <= m (易错!)。

参考链接:POJ2386 Lake Counting【DFS】

代码如下:

#include <iostream>
#define MAX 101
using namespace std;
int n, m;
char field[MAX][MAX];
void dfs(int x, int y) {
	field[x][y] = '.';
	for(int i = -1; i <= 1; i++)
		for(int j = -1; j <= 1; j++) {
			int nx = x + i;
			int ny = y + j;
			//判断是否在园子内且是否有积水
			if(nx > 0 && ny > 0 && nx <= n && ny <= m && field[nx][ny] == 'W') 
				dfs(nx, ny);
		}
}
int main() {
	int cnt = 0;
	cin>>n>>m;	
	for(int i = 1; i <= n; i++)
		for(int j = 1; j <= m; j++)
			cin>>field[i][j];
	for(int i = 1; i <= n; i++) 
		for(int j = 1; j <= m; j++) {
			if(field[i][j] == 'W') {
				cnt++;
				dfs(i, j);
			}
		}
	cout<<cnt<<endl;
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值