题目链接:新生晚会
Problem Description
开学了,杭电又迎来了好多新生。ACMer想为新生准备一个节目。来报名要表演节目的人很多,多达N个,但是只需要从这N个人中选M个就够了,一共有多少种选择方法?
Input
数据的第一行包括一个正整数T,接下来有T组数据,每组数据占一行。
每组数据包含两个整数N(来报名的人数,1<=N<=30),M(节目需要的人数0<=M<=30)
Output
每组数据输出一个整数,每个输出占一行
Sample Input
5
3 2
5 3
4 4
3 6
8 0
Sample Output
3
10
1
0
1
程序说明:
求组合数问题,由于n和m的范围都不大,直接根据递推式 ( a b ) \tbinom{a}{b} (ba) = ( a − 1 b ) \tbinom{a-1}{b} (ba−1) + ( a − 1 b − 1 ) \tbinom{a-1}{b-1} (b−1a−1)打表。
代码如下:
#include <iostream>
#include <cstdio>
using namespace std;
const int N = 35;
int c[N][N];
//打表
void init() {
for(int i = 0; i < N; i++)
for(int j = 0; j <= i; j++)
if(!j) c[i][j] = 1;
else c[i][j] = c[i - 1][j - 1] + c[i - 1][j];
}
int main() {
init();
int t;
scanf("%d", &t);
while(t--) {
int n, m;
scanf("%d%d", &n, &m);
printf("%d\n", c[n][m]);
}
return 0;
}