zcmu.oj-1091 查找单词

Description

输入一个正整数 repeat (0<repeat<10),做repeat 次下列运算:
输入一行字符,统计其中单词的个数。各单词之间用空格分隔,空格数可以是多个。

Input

见sample

Output

见sample

Sample Input

Every night in my dreams 
 I see you I feel you 
 That is how I know you go on

Sample Output

5
6
8


代码:

#include<stdio.h>
#include<string.h>
int main()
{
    int i,n,len,a,sum;
    scanf("%d\n",&n);
    for(i=0;i<n;i++)
    {
        char c[1000];
        gets(c);
        sum=0;
        len=strlen(c);
        if(c[0]!=' '){sum++;}
        for(a=0;a<len;a++)
        {

         if(c[a]==' '&&c[a+1]!=' '&&c[a+1]!='\0')

        {sum++;}

        }
        printf("%d\n",sum);
    }
    return 0;
    }
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值