杭电 1032【一种规律运算】

The 3n + 1 problem

Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.
You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.
You can assume that no opperation overflows a 32-bit integer.

Output
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).
 
Sample Input
  
  
1 10 100 200 201 210 900 1000
 
Sample Output
  
  
1 10 20 100 200 125 201 210 89 900 1000 174
 
/*
*
 if n = 1 then STOP
 if n is odd(奇数) then n <- 3n + 1
 else n <- n / 2
*
*题的大意是输入两个数(注意,这里没有说第一个数一定要小与第二个数),然后对这两个数之间的所有整数包括端点的数
*进行一种规律运算(如上所示),并求出运算的次数,比较所有的数规律运算次数,输出最大的.
*
*按照如上运算 22会得到:22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1这样16个数
*
*/
#include<iostream>
using namespace std;
int main()
{
	//A,B为所接收的两个数,a中存放较小的数,b中存放较大的数
    int n,m,a,b,i,k,A,B;
    while(cin>>A>>B)
    {
		//对输入的数A,B进行比较,使得a中存放的数为较小的数,使得b中存放的数为较大的数
        if(A>B)
        {b=A;a=B;}
        else
        {a=A;b=B;}
		//在每次计算之前对存放运算最大次数的m清零
        m=0;
		//按照题目要求从a到b包括a,b对每一个数进行运算
        for(i=a;i<=b;i++)
        {
			//将当前值赋值给k,根据题目所示,输入的数字本身也计算在内,因此n=1。
            n=1;k=i;
			//通过while对当前值进行运算,直到这个值变为1
            while(k!=1)
            {
				//按照题目要求,如果这个值是偶数则对其进行二分处理,并且运算次数记录器加1
                if(k%2==0)
                {n++;k=k/2;}
				//按照题目要求,如果这个值是奇数则对其乘3加1,并且运算次数记录器加1
                else
                {n++;k=3*k+1;}
            }
			//m中负责记录最大的运算次数,所以当运算次数记录器n中的值大于m,用n的值对m进行更新
            if(n>m)
            {m=n;}
        }
		//按照输出格式要求输出由键盘所输入的值A,B并输出带端点的此区间内以这种运算方法能得到的最大运算次数
        cout<<A<<" "<<B<<" "<<m<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值