Fibbonacci Number
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 22581 Accepted Submission(s): 10393
Problem Description
Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:
f(0) = 0
f(1) = 1
f(n) = f(n-1) + f(n-2)
Your program should be able to handle values of n in the range 0 to 50.
f(0) = 0
f(1) = 1
f(n) = f(n-1) + f(n-2)
Your program should be able to handle values of n in the range 0 to 50.
Input
Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.
Output
Print out the answer in a single line for each test case.
Sample Input
3 4 5 -1
Sample Output
2 3 5you can use 64bit integer: __int64HintNote:
Author
Lily
Source
Recommend
#include<stdio.h>
int main()
{
int n,i;
__int64 a[55];
a[0]=0;
a[1]=1;
for(i=2;i<51;i++)
a[i]=a[i-1]+a[i-2];
while(scanf("%d",&n))
{
if(n==-1)
break;
printf("%I64d\n",a[n]);
}
return 0;
}