hdu1754 I Hate It (线段树)

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
Output
对于每一次询问操作,在一行里面输出最高成绩。
Sample Input
5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5
Sample Output
5
6
5

9


这是一道单点替换,区间最大值的线段树。

只需要把区间求和的sum改为max就好了。代码见下:

#include <cstdio>
#include <cmath>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#include <numeric>
#include <set>
#include <string>
#include <cctype>
#define INF 0x3f3f3f3f
typedef long long LL;
using namespace std;
const int maxn=200000+5;
#define lson l, m, rt<<1
#define rson m+1, r, rt<<1|1

int n,m,a[maxn],Max[4*maxn];
char c[2];
void push_up(int rt)
{
    Max[rt]=max(Max[rt<<1],Max[rt<<1|1]);
}
void build (int l,int r,int rt)
{
    if (l==r) {Max[rt]=a[l];return;}
    int m=(l+r)>>1;
    build (lson);
    build (rson);
    push_up (rt);
}
void update(int p,int gai,int l,int r,int rt)
{
    if (l==r) {Max[rt]=gai;return;}
    int m=(l+r)>>1;
    if (p<=m) update(p,gai,lson);
    else update(p,gai,rson);
    push_up(rt);
}
int query(int L, int R, int l,int r,int rt)
{
    if(L<=l&&R>=r) return Max[rt];
    int m=(l+r)>>1;
    int ret=0;
    if (L<=m)  ret=max(ret,query(L,R,lson));
    if (R>m) ret=max(ret,query(L,R,rson));
    return ret;
}
int main ()
{
    //freopen ("in.txt","r",stdin);
    while (~scanf ("%d%d",&n,&m))
    {
        for (int i=1;i<=n;i++)
        {
            scanf ("%d",&a[i]);
        }
        build (1,n,1);
        while (m--)
        {
            int x,y;
            scanf ("%s%d%d",c,&x,&y);
            if (c[0]=='Q') printf ("%d\n",query(x,y,1,n,1));
            else update(x,y,1,n,1);
        }
    }
    return 0;
}

但这要注意的一点是c要么用string要么就得用c[2],这是做字符输入要注意的小地方,主要是自己经常搞错,找了半天错(逃

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值