POJ 1703:Find them, Catch them

点击就送屠龙宝刀

Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

  1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

  2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output
For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

题目大意
有两帮人打架JC叔叔要抓他们2333.但是我天朝的JC叔叔怎么会这么简单就把问题搞定呢!于是他们想知道某两个人是否属于同一个帮派。A i j 表示i 与j在同一个帮派,D i j 查询两个人是否在同一个帮派。答案有在一个帮派(In the same gang.)、不在同一个帮派(In different gangs.)、不知道(Not sure yet.)三种答案。
那么现在问题来了。共有t组数据,每组一个n一个m,表示一共n个人共m次询问,对于每一次询问输出一次答案。

解题思路:
首先是分成两组,这一定是个二分图!这一定是个二分图!这一定是个二分图!然而你也不看看数据范围。。。二分图+暴力查询绝对T的你不要不要的。。。。所以解法当然是并!查!集!~具体思路详见代码(这人明明没有写思路)

贴代码

#include<iostream>
using namespace std;

int f[100010];
bool nu[100010];    

int find(int x,bool &se)    
{
    se=true;
    int r=x;
    while(x!=f[x])
    {
        if(nu[x]==false)
            se=!se;
        x=f[x];
    }
    f[r]=x;         
    nu[r]=se;
    return x;
}
int main()
{
    int t,i,n,m,a,b,cnt=1;
    scanf("%d",&t);
    char str[3];
    while (t--)
    {
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
            f[i]=i,nu[i]=true;
        bool judge=true;
        while(m--)
        {
            scanf("%s%d%d",str,&a,&b);
            bool l1=0,l2=0;
            int fa=find(a,l1),fb=find(b,l2);
            if(str[0]=='D')
            {
                f[fa]=fb;
                nu[fa]=l1^l2;
            }
            else
            {
                if(fa==fb)      
                {
                    if(l1==l2)  
                        printf("In the same gang.\n");
                    else
                        printf("In different gangs.\n");
                }
                else        
                    printf("Not sure yet.\n");
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值