动态规划——Cutting Sticks

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery,
Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work
requires that they only make one cut at a time.
It is easy to notice that different selections in the order of cutting can led to different prices. For
example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end.
There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price
of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6.
Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 =
20, which is a better price.
Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.


Input

The input will consist of several input cases. The first line of each test case will contain a positive
number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will
contain the number n (n < 50) of cuts to be made.
The next line consists of n positive numbers ci (0 < ci < l) representing the places where the cuts
have to be done, given in strictly increasing order.
An input case with l = 0 will represent the end of the input.


Output

You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of
cutting the given stick. Format the output as shown below.


Sample Input

100
3
25 50 75
10
4
4 5 7 8
0


Sample Output

The minimum cutting is 200.

The minimum cutting is 22.



题意:给一个长为len的木棍,上面有n个切割点,每次切割的费用是当前要切割木棍的长度,要求把木棍上的切割点都切完,求所需要的最小费用。

这题刚开始我是这么想的:既然要最小费用,那就从最靠近当前棍中间位置的点开始切,这样费用肯定最少。

但是后来写的时候又想到既然要切完,那无论怎么切最后所得到的每根小棍的长度都不变, 例如第二个样例,无论怎么切,最后都会得到长度为4,1,2,1,2这五根木棍。

所以可以从最后的木棍开始往前合并,每次合并的费用为合并的木棍的长度和。但是要注意的是木棍只能和相邻的木棍合并。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int len;
int n;
int cost[60][60];     //保存每个区间的木棍长度
int dp[60][60];       //保存每个区间合并的费用
int main()
{
    while(~scanf("%d", &len)&&len)
    {
        scanf("%d", &n);
        int t=0;         //保存上个切割点的位置
        n++;            //棍上有n个切割点,加上左右端点就是n+2,刚好就是0~n+1
        memset(dp, 0, sizeof(dp));
        memset(cost, 0, sizeof(cost));
        for(int i=1; i<n; ++i)
        {
            int now;     //表示当前切割点的位置
            scanf("%d", &now);
            cost[i][i]=now-t;    //每段木棍的长度等于当前切割点-上个切割点的位置
            t=now;
        }
        cost[0][0]=0;         
        cost[n][n]=len-t;
        for(int l=0; l<len; ++l)
            for(int i=1; i+l<=n; ++i)
                for(int j=i; j+1<=i+l; j++)
                {
                    cost[i][i+l]=cost[i][j]+cost[j+1][i+l];     
                    if(!dp[i][i+l])                                          //如果i~i+1区间合并的费用为0
                        dp[i][i+l]=dp[i][j]+dp[j+1][i+l]+cost[i][i+l];      //就让它等于(i~j)+(j+1~i+l)的费用+i~i+l的长度
                    else
                        dp[i][i+l]=min(dp[i][i+l], dp[i][j]+dp[j+1][i+l]+cost[i][i+l]);  
                }
        printf("The minimum cutting is %d.\n", dp[1][n]);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值