HDU - 2819 Swap(最大匹配+输出路径)

Given an NN matrix with each entry equal to 0 or 1. You can swap any two rows or any two columns. Can you find a way to make all the diagonal entries equal to 1?
Input
There are several test cases in the input. The first line of each test case is an integer N (1 <= N <= 100). Then N lines follow, each contains N numbers (0 or 1), separating by space, indicating the N
N matrix.
Output
For each test case, the first line contain the number of swaps M. Then M lines follow, whose format is “R a b” or “C a b”, indicating swapping the row a and row b, or swapping the column a and column b. (1 <= a, b <= N). Any correct answer will be accepted, but M should be more than 1000.

If it is impossible to make all the diagonal entries equal to 1, output only one one containing “-1”.
Sample Input
2
0 1
1 0
2
1 0
1 0
Sample Output
1
R 1 2
-1

题意: 一个由0和1 组成的n*n棋盘,能否通过交换行或列使得对角全为1.
思路: 要使得矩阵的对角线全为1,则每行或每列至少有一个1,即行与列的最大匹配数为n,这样通过交换行或列达到目标。
那么判断是否能过构成对角1的矩阵后,该如何交换呢?
首先我们要知道我们达到的目标是什么,即mp [i][i] = 1,那么对于这个图来说,我所匹配的link[i] = i.所以,我们可以通过记录的link实现交换的目的。
对于Y部来说,link[i]记录的是匹配的X部。假设link[i] = x,link[x] = y;交换他们之间的值便可达到link[x] = x.即swap(link[i],link[link[i]])。
代码:

#include<bits/stdc++.h>
using namespace std;
const int MAXN = 110;
struct Edge
{
    int v,next;
}e[MAXN*MAXN];
int head[MAXN],link[MAXN];
bool vis[MAXN];
int n,cnt;

void init()
{
    for(int i = 0; i <= n; ++i) head[i] = link[i] = -1;
    cnt = 0;
}

void addedge(int u,int v)
{
    e[cnt].v = v;
    e[cnt].next = head[u];
    head[u] = cnt++;
}

bool dfs(int x)
{
    for(int i = head[x]; ~i; i = e[i].next){
        int y = e[i].v;
        if(vis[y])  continue;
        vis[y] = true;
        if(link[y] == -1 || dfs(link[y])){
            link[y] = x;
            return true;
        }
    }
    return false;
}

int solve()
{
    int ans = 0;
    for(int i = 1; i <= n; ++i){
        memset(vis,false,sizeof(vis));
        ans += dfs(i);
    }
    return ans;
}

int main()
{
    while(~scanf("%d",&n)){
        init();
        for(int i = 1; i <= n; ++i){
            for(int j = 1; j <= n; ++j){
                int x;  scanf("%d",&x);
                if(x) addedge(i,j);
            }
        }
        int ans = solve();
        if(ans != n){cout<<-1<<endl;continue;}
        int k = 0,a[MAXN],b[MAXN];
        for(int i = 1; i <= n; ++i){
            while(i != link[i]){
                a[k] = i;
                b[k] = link[i];
                swap(link[i],link[link[i]]);
                k++;
            }
        }
        cout<<k<<endl;
        for(int i = 0; i < k; ++i)
            printf("C %d %d\n",a[i],b[i]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值