ZOJ-1610 Count the Colors(线段树,区间更新)

题目链接 http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1610

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.
Your task is counting the segments of different colors you can see at last.

Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.
Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.

Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.
If some color can’t be seen, you shouldn’t print it.

Print a blank line after every dataset.

Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1

Sample Output

1 1
2 1
3 1
1 1

0 2
1 1`

题意:有一根线,n次操作,每次对线的一个区间进行染色,后面的颜色可以覆盖之前的颜色
问最后有多少种颜色,每种颜色有多少段?`

思路:以区间为对象建树,待区间跟新时覆盖时,用lazy成段更新一下就好。

总结与分析:
线段树刚刚入门,对线段树的操作还不是很熟悉,经常犯一些低级的错误,特意在这里总结一下错误原因。

1.题目中区间的染色是一段一段的染色,而不是一个点一个点的染色。
例【1,3】 是将(1,2),(2,3)染色,而不是将1,2,3三个点染色。

2.更新区间时,需要判断染色区间与当前区间的关系,而区间查询时不需要

3.判断相邻区间颜色是否相同,可以在区间查询时用vis标记一下上一个区间的颜色。

4.最后提交样例一直过不去,原来是初始化的位置写错了,每更新一次区间初始化一次,这样肯定时过不去的,找了一天的bug~~

#include<iostream>
#include<cstring>
#include<cmath>
#include<queue>
#include<stack>
#include<cstdio>
using namespace std;
const int MAXN = 8010;

int col[MAXN<<2],ans[MAXN],vis;

void pushdown(int rt)
{
    col[rt<<1] = col[rt<<1|1] = col[rt];
    col[rt] = -1;
    return ;
}

void update(int rt,int L,int R,int l,int r,int c)
{
    if(l<=L && R<=r){
        col[rt] = c;
        return ;
    }
    if(col[rt] == c)  return ;
    if(col[rt] != -1)   pushdown(rt);
    int Mid = (L+R)>>1;
    if(l <= Mid) update(rt<<1,L,Mid,l,r,c);
    if(Mid < r) update(rt<<1|1,Mid+1,R,l,r,c);
}

void query(int rt,int l,int r)
{
    if(l == r){
        if(col[rt] != -1 && col[rt] != vis){    //判断当前区间是否染色,颜色是否和上一个区间的颜色相同
            ans[col[rt]]++;
        }
        vis=col[rt];    //标记区间颜色
        return ;
    }
    if(l == r)  return ;
    if(col[rt]!=-1)    pushdown(rt);    //将区间向下传,直至叶子节点。(从一段区间的染色变为单位区间的染色)
    int Mid = (l+r)>>1;
    query(rt<<1,l,Mid);
    query(rt<<1|1,Mid+1,r);
}

int main()
{
    int n;
    while(cin>>n){
        memset(col,-1,sizeof(col));
        while(n--){
            int l,r,c;
            scanf("%d%d%d",&l,&r,&c);
            update(1,1,8000,l+1,r,c);   //(l+1成功的解决了问题4)
        }
        memset(ans,0,sizeof(ans));
        vis=-1;
        query(1,1,8000);
        for(int i=0;i<=8000;i++)    if(ans[i])    printf("%d %d\n",i,ans[i]);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值