Uniform Generator hdu-1014

该博客讨论了如何通过函数seed(x+1) = [seed(x) + STEP] % MOD生成伪随机数,并强调了选择合适的STEP和MOD以实现均匀分布的重要性。问题在于判断给定的STEP和MOD组合是否能确保所有0到MOD-1的数字在MOD次迭代后都出现。题目给出了具体的输入输出格式和样例,并提供了两种解题思路:暴力求解和判断互质关系。
摘要由CSDN通过智能技术生成

题目来源:hdu-1014

Uniform Generator
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22038 Accepted Submission(s): 8671

Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where ‘%’ is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either “Good Choice” or “Bad Choice” left-justified starting in column 25. The “Good Choice” message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message “Bad Choice”. After each output test set, your program should print exactly one blank line.

Sample Input
3 5
15 20
63923 99999

Sample Output
3 5 Good Choice

    15        20    Bad Choice

 63923     99999    Good Choice

Source
South Central USA 1996

题目大意:
输入两个数step,mod;求mod次seed的值,seed=(seed+step)%mod。若seed均在0~mod-1中出现一次,极为Good,否则为Bad。
解题思路:
可以直接暴力。。。另外一种方法,就是求两个数是否互质,是为Good,否则为Bad。
暴力AC代码:

#include<string.h>
#include<stdio.h>
using namespace std;
int main()
{
    int step,mod;
    while(scanf("%d%d",&step,&mod)!=EOF)
    {
        int seed=0;
        int flag=0;
        for(int i=0;i<mod;i++)
        {
            seed=(seed+step)%mod;
            if(seed==0)
            {
                if(mod-1==i)
                    flag=1;
                break;
            }
        }
        if(flag)
            printf("%10d%10d    Good Choice\n\n",step,mod);
        else
            printf("%10d%10d    Bad Choice\n\n",step,mod);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值