链接
题目描述
被所有奶牛喜欢的奶牛就是一头明星奶牛。每头奶牛总是喜欢自己的,奶牛之间的“喜欢”是可以传递的——如果 A 喜欢 B,B 喜欢 C,那么 A 也喜欢 C。牛栏里共有N头奶牛,给定一些奶牛之间的喜欢关系,请你算出有多少头奶牛可以当明星。
样例输入
3 3
1 2
2 1
2 3
样例输出
1
思路
我们可以想,既然喜欢可以传递,那么也就是只要一个点能到另一个点也可以返回,那么我们就可以得知这条路径上的所有点都是互相喜欢的,那就可以缩成一个点来处理,同时记录这个缩点的点的个数
那我们来考虑如何才能成为所有牛都喜欢的明星
在缩点后,我们来寻找一个点——此点出度为0,若此点只有一个,则说明图上其他点都可以到达此点,那么此点的所有牛都是明星,那如果这个点不只一个,那就没有明星
代码
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int tt, t, p, top, n, m, ans, anss;
int h[10005], num[10005], sum[10005];
int s[10005], dfn[10005], low[10005], col[10005];
struct node
{
int from, to, next;
}g[100005];
void add(int x, int y)
{
g[++t] = (node){x, y, h[x]}; h[x] = t;
}
void Tarjan(int x)
{
dfn[x] = low[x] = ++tt;
s[++top] = x;
for(int i = h[x]; i; i = g[i].next)
{
int to = g[i].to;
if(!dfn[to])
{
Tarjan(to);
low[x] = min(low[x], low[to]);
}
else if(!col[to]) low[x] = min(low[x], low[to]);
}
if(dfn[x] == low[x])
{
col[x] = ++p;
sum[p]++;
while(s[top] != x)
{
sum[p]++;
col[s[top--]] = p;
}
top--;
}//缩点
}
int main()
{
scanf("%d%d", &n, &m);
for(int i = 1; i <= m; ++i)
{
int a, b;
scanf("%d%d", &a, &b);
add(a, b);
}
for(int i = 1; i <= n; ++i)
if(!dfn[i]) Tarjan(i);
for(int i = 1; i <= t; ++i)
{
int to = g[i].to, from = g[i].from;
if(col[to] != col[from])
num[col[from]]++;
}//统计图上每个点的出度
for(int i = 1; i <= p; ++i)
if(num[i] == 0) ans += sum[i], anss++;
if(anss == 1) printf("%d", ans);
else printf("0");
return 0;
}