Jessica's Reading Problem

Jessica’s a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica’s text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input
The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica’s text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output
Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input
5
1 8 8 8 1
Sample Output
2
emmmmm,题意是一个妹子要复习了,然后一本书上每一页是一个知识点,问你最少看多少页可以看完全部的知识点。
这个题的思路仍然是尺取法,我们需要检测已有的序列中出现的知识点的总数,和书本实际的知识点的总数进行比较就可以知道是否覆盖全部的知识点了(尺取法的思想见另一篇博文,subsequence)
这个题用了set来记录知识点的总个数(这是个黑科技,set中相同的结点只会出现一次,所以set的size就是知识点的总个数)
我们用map来记录每个知识点出现的次数,如果某个知识点出现次数为0就一直扩大尺的长度,如果出现新结点尺的长度就往后缩1
这样循环到最后就可以知道至少读几页可以涵盖所有知识点了
代码如下://如有错误欢迎指正(代码和挑战的一样哈哈哈哈)

#include<iostream>
#include<set>
#include<map>
#include<algorithm>
#include<memory>
using namespace std;
int p;
int a[1000000];
void solve()
{//set 可以使每个值只出现一次
	set<int>all;
	for (int i = 0; i < p; i++)
		all.insert(a[i]);
	int n = all.size();
 //尺取法
	int s = 0, t = 0, num = 0;
	map<int,int>count;
	int ans = p + 1;
	for (;;)
	{
		while (t < p&&num < n)
		{
			if (count[a[t++]]++ == 0)
				num++;//出现新节点
		}
		if (num < n)break;
		ans = min(ans, t - s);
		if (--count[a[s++]] == 0)
			num--;//某个知识点出现次数为0
	}
	printf("%d\n", ans);
}
int main()
{
	while (cin >> p)
	{
		memset(a,0, sizeof(a));
		for (int i = 0; i < p; i++)
			cin >> a[i];
		solve();
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值