WOJ1039-Key

As an employee of the Amaze Combines with Magicpig company, Kinfkong has been asked to store some integer keys. The keys must be stored

in a special ordered collection that can be considered as an array A, which has an infinite number of locations, numbered starting from 1.
Initially all locations are empty. The following operation must be supported by the collection:
Insert(L, K), where L is the location in the array and K is a positive integer value.
The operation must be processed as follows:
If A[L] is empty, set A[L] = K.
If A[L] is not empty, perform Insert(L + 1, K).
These days Kinfkong is too busy, so he asks you to help him!
Given N integer numbers L1 , L2 , . . . , LN, you have to output the contents of the array after a sequence of the following operations:
Insert(L1 , 1)
Insert(L2 , 2)
. . .
Insert(LN , N)

输入格式

The first line of the input file contains N --- the number of Insert operations (1 <= N <= 100000).

Next line contains N integer numbers Li that describe Insert operations to be performed (1 <= Li <= N ).
A line which contains a single 0 will end the input.

输出格式

Output the contents of the array after a given sequence of Insert operations. On the first line print W --- the number of the greatest location

that is not empty. After that output W integer numbers --- A[1], A[2], . . . , A[W] ,separated by a single space. Output zeroes for empty locations.

样例输入

5
3 3 4 1 3
0

样例输出

6
4 0 1 2 3 5


#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <algorithm>   
//初始时每个点的父节点是自己本身,插入一个数后和他后面的一个数合并,并设置一个数更新出现值的最大位置
using namespace std;  
const int MAX=200005;  
int father[MAX]; //father[i]表示i的父节点  
int v[MAX];//所在位置的值  
int cmax;//含值的最大位置  
int findset(int x)  
{
	//return father[x]==x?x:father[x]=findset(father[x]);
    while (x != father[x]) x = father[x];  
    return x;  
}  
  
void Union(int x, int y){  
    x = findset( x ); //查找 x 的祖先  
    y = findset( y ); //查找 y 的祖先  
    if(x == y) return ;  
    father[x] = y; //合并后祖先为 y  
    if(y>cmax) cmax=y;  
}  
  
int main()  
{  
    int n,i;  
    while(cin>>n&& n){  
        cmax=1;
        for(i=0;i<MAX;i++){  
            father[i]=i; v[i]=0;  
        }  
        for(i=1;i<=n;i++)  
        {  
            int tmp,f;  
            cin>>tmp;  
            father[tmp]=findset(tmp);  
            if(tmp== father[tmp]){  
                v[tmp]=i;  
                Union(tmp,tmp+1);  
            }  
            else{  
                v[father[tmp]]=i;  
                Union(father[tmp],father[tmp]+1);  
            }  
        }  
        if(v[cmax]==0) cmax--;  
        	cout<<cmax<<endl;  
        for(i=1;i<=cmax;i++){  
            cout<<v[i];  
            if(i<cmax) cout<<" ";  
        }  
        cout<<endl;  
    }  
    return 0;  
}  



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值