WOJ1080-Game

Flymouse and snoopy play the game of addition by adding an integer p with a number m(1<=m<=13) in each turn. Since flymouse is younger, 
he always starts with p = 0,does his addition, then snoopy adds the number,then flymouse and so on. Before a game starts, they draw an 
integer 1 < n < 10^9 and the winner is who first reach p == n.

输入格式

Standard input will contain multiple test cases. The first line of the input if a single integer T which is the number of test cases.
For each test case,there is one line containing one integer number n.

输出格式

For each test case,output one line either
flymouse wins the game! or snoopy wins the game! assuming that both of them play perfectly.

样例输入

2
9
14

样例输出

flymouse wins the game!
snoopy wins the game!
选的数为14的倍数后手赢,其余先手赢


#include<stdio.h>
int main(){
	int t,n,i;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		i=n%14;
		if(i==0)
		printf("snoopy wins the game!\n");
		else
		printf("flymouse wins the game!\n");			
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值