WOJ1157-Easy to Count

There are N boxes on one straight line which is long enough.
They move at the same speed, but their directions may be different. That is, some boxes
may move left, while the others move right. As a beautiful girl fond of algorithm and
programming, Alice finds that two boxes moving toward each other will collide, and
after collision their directions change while their speeds remain the same. Alice also
knows that the boxes will not collide any more after many times of collision, she names
this final status as the stable status. The task is to help her count the number of
collisions before reach the stable status.

输入格式

There are multiple test cases. For each test case, the first line is an integer N (1 <= N <= 10000) representing the number of boxes, and the second line is N integers,
separated by spaces. The i-th integer will be -1 if the i-th box move left, otherwise, it will be 1.
N = -1 indicates the end of input and should not be processed by your program.

输出格式

For each test case, output an integer which is the number of collisions to reach the
stable status on a single line in the format as indicated.

样例输入

3
1 -1 1
4
1 -1 1 -1
-1

样例输出

Case 1: 1
Case 2: 3

累加每个-1左边的1的个数,输出

#include<stdio.h>
int main(){
	int n,i,a,ans,count,c=0;
	while(scanf("%d",&n)==1&&n!=-1){
		c++;
		count=ans=0;
		for(i=0;i<n;i++){
			scanf("%d",&a);
			if(a==1)
			count++;
			else if(a==-1)
			ans+=count;
		}
		printf("Case %d: %d\n",c,ans);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值