WOJ1187-Difference Minimizing

Ginger's supervisor Mr. Zhang has great interest in arithmetic; today, Mr. Zhang left her a problem, the last problem of IPRAI's 2nd Round GS-Examination. Can you help the poor little girl to find out how to minimize the sum difference of two piles of numbers?
The problem seems so simple: there are K positive integers; her mission is to divide them into two piles, so that the sums of two piles are the closest.

输入格式

There are several test cases. Each test case contains two lines.
The first line contains an integer K (1 < K < 100) .
The second line contains K integers, X (1 < X < 100) .

输出格式

For each test case, print the minimum difference in one line.

样例输入

3
5 1 2

6
18 5 5 5 5 2

样例输出

2
0

裸的01背包

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int n,sum,target,*dp,data[100];
int main(){
    int i,j;
    while(~scanf("%d",&n)){
        sum=0;
        for(i=0;i<n;i++){
            scanf("%d",&data[i]);
            sum+=data[i];
        }
        target=sum/2;
        dp=(int*)calloc(sum+1,4);
        dp[0]=1;
        for(i=0;i<n;i++)
            for(j=target;j>=data[i];j--)
                if(dp[j-data[i]])
                    dp[j]=1;
        for(i=target;i>=0;i--)
            if(dp[i])
                break;
        printf("%d\n",sum-2*i);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值