POJ-2406 Power Strings (KMP)

Problem Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Ouput

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

思路

这几天看KMP看的云里雾里……好像有点理解了它的思想了。关于这道题目,首先根据KMP的思想求出给定字符串对应的next数组,可知len-next[len]为该字符串最短循环子串的长度,若len%(len-next[len]) == 0则存在n符合题意,否则不存在。关于这个思想的理解我是参考了博客POJ 2406 Power Strings (KMP) 总觉得还要再好好理解理解KMP啊(雾

代码

#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<string.h>

using namespace std;

char str[1000010];
int len, ans, next[1000010];

void getNext() {
    int i = 0, j = -1;
    next[0] = -1;
    while(i < len) {
        if (j == -1 || str[i] == str[j]) {
            i++;
            j++;
            next[i] = str[i] != str[j] ? j : next[j];

        }
        else
            j = next[j];
    }
}

int main() {
    while(scanf("%s", str)) {
        if(str[0] == '.')
            break;
        len = strlen(str);
        getNext();
        if(len % (len - next[len]) == 0)
            ans = len / (len - next[len]);
        else
            ans = 1;
        cout << ans << endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值