POJ 1442 Black Box (优先队列)

Black Box
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6246 Accepted: 2532

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2


题意:给定M个数,每次可以插入序列一个数;再给N个数,表示在插入第几个数时输出一个数,第一次输出序列中最小的,第二次输出序列中第二小的……以此类推,直到输出N个数。


分析:因为输出时是按照先输出最小的,再输出第二小这样的方式输出的,相当于依次输出一个有序序列中的值。但因为这个序列不是固定不变的,而是不断的在更新,所以用数组是无法实现的。我们可以用优先队列来做。

定义两个优先队列,一个用来存储前k小的数,大数在前,小数在后;另一个优先队列第k+1小到最大的数,小数在前,大数在后。每次拿到一个数,先判断第一个优先队列中的数满不满k个,如果不满k个,则直接把这个数压入到第一个队列;如果满k个,判断这个数和第一个优先队列中的第一个数的大小:如果比第一个数大,就压入第二个优先队列;如果比第一个数小,就把第一个优先队列的队首元素弹出压入第二个队列,把这个新数压入第一个优先队列。

输出时,如果第一个优先队列里的元素个数小于k,则先把第二个优先队列里的队首元素弹出压入第一个优先队列,然后输出第一个优先队列的队首元素;如果满k个,则直接输出第一个优先队列的队首元素。


代码实现:

#include<cstdio>
#include<queue>
using namespace std;
int a[30010], u[30010];
int main()
{
	int n, m, i, j, k, x, ans;
	while(~scanf("%d%d",&m,&n))
	{	
		priority_queue<int, vector<int>, less<int> > que1;  //队列中的元素从大到小排序
		priority_queue<int, vector<int>, greater<int> > que2;   //队列中的元素从小到大排序
		for(i = 1; i <= m; i++)
			scanf("%d",&a[i]);
		for(j = 1; j <= n; j++)
			scanf("%d",&u[j]);
		i = 0;
		j = k = 1;
		while(j <= n)
		{
			if(i == u[j])  //弹出第k小的数
			{
				j++;
				if(que1.size() < k) //que1里的元素不够k个
				{
					x = que2.top();
					que1.push(x);
					que2.pop();
				}
				ans = que1.top(); 
				printf("%d\n",ans);
				k++;  //每次弹出一个数后,k的值都要加1
			}
			else
			{
				i++;
				//que1里的元素不够k个
				if(que1.size() < k) 
				{
					que2.push(a[i]); 
					x = que2.top();	
					que2.pop();
					que1.push(x);  //先把a[i]压入que2,再从que2里取出最小值,压入que1
				}

				//如果que1的元素达到k个,且要压入队列的值比que1中的当前最大值大,说明que1中当前的最大值并不是第k小
				else if(que1.top() > a[i])
				{ 
					x = que1.top();
					que1.pop();
					que2.push(x);
					que1.push(a[i]);
				}
				//que1中的元素个数达到k个,且要压入队列的值比que1中的当前最大值小,说明que1中当前的最大值就是是第k小,则把a[i]直接压入que2中
				else
				{
					que2.push(a[i]);
				}
			}
		}
	}
	return 0;
}





  • 3
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值