hdu 1052 Tian Ji -- The Horse Racing

Tian Ji -- The Horse Racing

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

Sample Output

200
0
0
题目链接(二)NYOJ364

设田忌为a,国王为b,如果两队所有未比赛的马中,先对速度从大到小排序,然后:

一、如果a的最快速度大于b的最快,则直接a的最快与b的最快比赛,赢一场;

二、如果a的最快速度小于b的最快,则用a的最慢浪费b的最快,输一场;

三、如果a的最快速度等于b的最快,则:

1.如果a的最慢速度大于b的最慢,则直接a的最慢与b的最慢进行比赛,赢一场;

2.如果b的最慢速度小于b的最慢,则用a的最慢浪费b的最快,输一场;

3.如果a的最慢速度等于b的最慢,即a与b的最慢与最快分别相等,则:先用a的最慢与b的最快比,然后找出新的最快和最慢,重复上面的比较,直到所有马都比完。

代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
bool cmp(int a,int b)
{
    return a>b;
}
int main()
{
    int n,i,win,ti,tj,ki,kj;
    int T[1005],K[1005];//T表示田忌,K表示King
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        for(i=0;i<n;i++)
          scanf("%d",&T[i]);
        for(i=0;i<n;i++)
          scanf("%d",&K[i]);
        sort(T,T+n,cmp);
        sort(K,K+n,cmp);  //对马的速度从大到小排序
        ki=ti=0;
        kj=tj=n-1;  //t表示田忌,k表示king
        for(i=0,win=0;i<n;i++)  //开始时win=0,即不输也不赢
        {
           if(T[ti]<K[ki])  //田忌最快的马比国王最快的马慢,用最慢的马与国王最快的马比
           {
              tj--;
              ki++;
              win--;
           }
           else if(T[ti]>K[ki])  //田忌最快的马比国王最快的马快,用最快的马与国王最快的马比
           {
               ki++;
               ti++;
               win++;
           }
           else  //最快速度相同
           {
               if(T[tj]>K[kj])  //田忌最慢的马比King最慢的马快,用最慢的与king最慢的比
               {
                   tj--;
                   kj--;
                   win++;
               }
               else if(T[tj]<K[kj])//田忌最慢的马比King最慢的马慢,用最慢的与king最快的比
               {
                   tj--;
                   ki++;
                   win--;
               }
               else  //最慢速度和最快速度都相同
               {
                   if(T[tj]<K[ki]) //先用田忌的慢马与king的快马比,再用田忌的快马与king的慢马比
                   {
                       tj--;
                       ki++;
                       win--;
                   }
               }
           }
        }
        printf("%d\n",win*200);
    }
    return 0;
}


下面是一个简单好想的代码:
#include<stdio.h>
#include<algorithm>
using namespace std;
int t[1005], k[1005];
int main()
{
    int n, i;
    while(~scanf("%d",&n) && n)
    {
        for(i = 0; i < n; i++)
            scanf("%d",&t[i]);
        for(i = 0; i < n; i++)
            scanf("%d",&k[i]);
        sort(t, t+n);
        sort(k, k+n);
        int ans = 0;
        int l1 = 0, r1 = n - 1, l2 = 0, r2 = n - 1;
        while(l1 <= r1)
        {
            if(t[l1] > k[l2])
            {
                ans++;
                l1++;
                l2++;
            }
            else if(t[r1] > k[r2])
            {
                ans++;
                r1--;
                r2--;
            }
            else
            {
                if(t[l1] < k[r2]) ans--;
                l1++;
                r2--;
            }
        }
        printf("%d\n",ans*200);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值