hdu 2844 Coins 多重背包

Coins

                                                                            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
  
  
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
  
  
8 4
题目链接: 点击打开链接
多重背包:每个物体的数量不止一件,通常把多重背包转化为01背包和完全背包来求。这个题中的a[i]既是物体的体积,又是物体的价值,c[i]是物体的数量。最后判断dp[i]==i是否成立,即判断能否组合成不超过m的任意一个数(不用找钱),如果可以,计数器加1;最后输出计数器的大小。
参考代码如下:
#include<stdio.h>
#include<string.h>
int a[102],c[102],dp[100005];
int max(int a,int b)
{
    return a>b?a:b;
}
void CompletePack(int v,int w,int m) //完全背包
{
     for(int j=v;j<=m;j++)
      dp[j]=max(dp[j],dp[j-v]+w);
}
void ZeroOnePack(int v,int w,int m) //01背包
{
      for(int j=m;j>=v;j--)
       dp[j]=max(dp[j],dp[j-v]+w);
}
void MultiPack(int v,int w,int m,int c) //多重背包
{
    if(v*c>=m) //体积乘以数量大于总体积,说明不能完全装完,相当于有无穷件,用完全背包
     CompletePack(v,w,m);
    else  //可以装完,用01背包
    {
        int k=1;
        while(k<c) //二进制优化
        {
            ZeroOnePack(k*v,k*w,m);
             c-=k;
             k*=2;
        }
        ZeroOnePack(c*v,c*w,m);
    }
}
int main()
{
    int n,i,j,m,k;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0) break;
        for(i=0;i<n;i++)
         scanf("%d",&a[i]);  //a[i]既是物体的体积,又是物体的价值
        for(i=0;i<n;i++)
         scanf("%d",&c[i]); //c[i]是物体的数量
        memset(dp,0,sizeof(dp));
        for(i=0;i<n;i++)
        {
            MultiPack(a[i],a[i],m,c[i]);
        }
        int count=0; //计数
        for(i=1;i<=m;i++)
         if(dp[i]==i)  //可以组合且不用找钱
          count++;
        printf("%d\n",count);
    }
    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值