UVA 146 - ID Codes 枚举排列

12 篇文章 0 订阅

                                         ID Codes

It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure--all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people's movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.)

An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set.

For example, suppose it is decided that a code will contain exactly 3 occurrences of `a', 2 of `b' and 1 of `c', then three of the allowable 60 codes under these conditions are:

      abaabc
      abaacb
      ababac

These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order.

Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message `No Successor' if the given code is the last in the sequence for that set of characters.

Input and Output

Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single #.

Output will consist of one line for each code read containing the successor code or the words `No Successor'.

Sample input

abaacb
cbbaa
#

Sample output

ababac
No Successor
题意:求一个确定字母数量的排列的下一个排列。即求将这些字母全排列后与给定排列相邻的下一个排列是什么。字典序大小排列。

法一:
从后向前找第一个后面字母比前面字母大的字母,然后在它之后找比它大的字母中最小的,交换之后,把这个字母后面的字母按升序排列。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int i,len,p;
    char str[60];
    while(cin>>str&&str[0]!='#')
    {
        len=strlen(str);
        for(p=len-1;p>0;p--)
          if(str[p]>str[p-1])
            break;
        if(p==0)  /*字典序最大*/
        {
            cout<<"No Successor"<<endl;
            continue;  
        }
        for(i=len-1;i>=p;i--)
        {
            if(str[i]>str[p-1])
            {
                char temp=str[i];
                str[i]=str[p-1];
                str[p-1]=temp;
                break;
            }
        }
        sort(str+p,str+len);
        cout<<str<<endl;
    }
    return 0;
}

法二:直接用STL里面的next_permutation函数求下一个排列,与所给的排列比较是否相同。如果不同,则输出;否则,输出No Successor
下面是一些大牛的代码:
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
 
int main() {
    string s;
    while (cin >> s && s != "#") {
        if (next_permutation(s.begin(), s.end()))
            cout << s << endl;
        else
            cout << "No Successor" << endl;
    }
    return 0;
}
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	char code[100],judge[100];
	int n;
	while(cin >> code)
	{
		if(code[0] == '#')break;
		n = strlen(code);
		strcpy(judge,code);
		sort(judge,judge+n);	//最大排列的下一排列为最小排列,故sort排出最小排列
		next_permutation(code,code + n);
		if(strcmp(code,judge) != 0)//比较当前排列的下一排列与最小排列,若相同则当前排列是最大排列
			cout << code <<endl;
		else
			cout << "No Successor"<<endl;
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值