UVA 10487 - Closest Sums

Closest Sums
Input: standard input
Output: standard output
Time Limit: 3 seconds

 

Given is a set of integers and then a sequence of queries. A query gives you a number and asks to find a sum of two distinct numbers from the set, which is closest to the query number.

Input

Input contains multiple cases.

Each case starts with an integer n (1<n<=1000), which indicates, how many numbers are in the set of integer. Next n lines contain n numbers. Of course there is only one number in a single line. The next line contains a positive integer m giving the number of queries, 0 < m < 25. The next mlines contain an integer of the query, one per line.

Input is terminated by a case whose n=0. Surely, this case needs no processing.

Output

Output should be organized as in the sample below. For each query output one line giving the query value and the closest sum in the format as in the sample. Inputs will be such that no ties will occur.

Sample input

5

3
12
17
33
34
3
1
51
30
3
1
2
3
3
1
2
3

3

1
2
3
3
4
5
6
0

Sample output

Case 1:
Closest sum to 1 is 15.
Closest sum to 51 is 51.
Closest sum to 30 is 29.
Case 2:
Closest sum to 1 is 3.
Closest sum to 2 is 3.
Closest sum to 3 is 3.
Case 3:
Closest sum to 4 is 4.
Closest sum to 5 is 5.
Closest sum to 6 is 5.
 
 
 
题目大意:
给出由一些数字组成的集合,然后再输入一个字, 找出集合中不同的两个数的和最接近输入这个数的值
解题思路: 先求出这个集合中任意两个数的和,然后进行排序,最后查找。因为数据规模比较小,所以可以一个一个比较。
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int a[1005],s[1000005],q[30];
int main()
{
	int i,j,p,n,m,k,cas=0;
	while(~scanf("%d",&n)&&n)
	{
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(i=0,k=0;i<n-1;i++)
			for(j=i+1;j<n;j++)
				s[k++]=a[i]+a[j];
		sort(s,s+k);
		scanf("%d",&m);
		for(i=0;i<m;i++)
			scanf("%d",&q[i]);
		printf("Case %d:\n",++cas);
		for(j=0;j<m;j++)
		{
			if(q[j]<=s[0])
				p=s[0];
			else if(q[j]>=s[k-1])
				p=s[k-1];
			else
			{
				for(i=0;i<k;i++)
				{
					if(s[i]<q[j])
					     continue;
					else
					{
						p=abs(s[i]-q[j])<abs(s[i-1]-q[j])?s[i]:s[i-1];
						break;
					}
				}
			}
			printf("Closest sum to %d is %d.\n",q[j],p);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值