Day of week - 九度教程第7题

Day of week - 九度教程第7题

题目

时间限制:1 秒 内存限制:32 兆 特殊判题:否
题目描述:
We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400. For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s
agreement about dating.
输入:
There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.
输出:
Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.
样例输入:
9 October 2001
14 October 2001
样例输出:
Tuesday
Sunday
来源:
2008年上海交通大学计算机研究生机试真题

其大意为,输入一个日期,要求输出该日期为星期几。
星期几是以七为周期循环的,那么只需要知道:1.今天是星期几;2.今天和所给定的那天相隔几天。利用其对7求余数便可以知道所给定的那天是星期几。

代码

#include <stdio.h>
#include <string.h>
#define ISLEAPYEAP(x) (x%100!=0 && x%4 == 0) || x%400==0 ? 1 : 0

int dayOfMonth[13][2] = {
    0,0,
    31,31,
    28,29,
    31,31,
    30,30,
    31,31,
    30,30,
    31,31,
    31,31,
    30,30,
    31,31,
    30,30,
    31,31
};

struct Date {
    int Day;
    int Month;
    int Year;
    void nextDay() {
        Day ++;
        if (Day > dayOfMonth[Month][ ISLEAPYEAP(Year) ]) {
            Day = 1;
            Month ++;
            if (Month > 12) {
                Month = 1;
                Year ++;
            }
        }
    }
};

int buf[3001][13][32];
char monthName[13][20] = {
    "",
    "January",
    "February",
    "March",
    "April",
    "May",
    "June",
    "July",
    "August",
    "September",
    "October",
    "November",
    "December"
}; //月名每个月名对应下标1到12

char weekName[7][20] = {
    "Sunday",
    "Monday",
    "Tuesday",
    "Wednesday",
    "Thursday",
    "Friday",
    "Saturday"
}; //周名每个周名对应下标0到6

int main () {
    Date tmp;
    int cnt = 0;
    tmp.Day = 1;
    tmp.Month = 1;
    tmp.Year = 0;
    while(tmp.Year != 3001) {
        buf[tmp.Year][tmp.Month][tmp.Day] = cnt;
        tmp.nextDay();
        cnt ++;
    } //预处理出每一天与原点日期的天数差
    int d , m, y;
    char s[20];
    while (scanf ("%d%s%d",&d,s,&y) != EOF) {
        for (m = 1;m <= 12;m ++) {
            if (strcmp(s,monthName[m]) == 0) {
                break; //将输入字符串与月名比较得出月数
            }
        }
        int days = buf[y][m][d] - buf[2019][2][25]; //计算给定日期与今日日期的天数间隔(注意可能为负)
        days += 1; //2019.2.25为星期一,对应数组下标为1,则计算1经过days天后的下标
        puts(weekName[(days % 7 + 7) % 7]); //将计算后得出的下标用7对其取模,并且保证其为非负数,则该下标即为答案所对应的下标,输出即可
    }
    return 0;
}

处理出每个日期与原点日期之间的天数间隔(依然选用0年1月1日为原点日期,实际上原点日期可以按照要求任意选取)。然后计算该日期与当前日期的天数间隔。若间隔为正,则表示目标日期在当前日期之后;若为负,则表示目标日期在当前日期之前。
同时将周日到周一分别对应数组下标0到6(与保存周名数组保持一致),当前日期为星期一,固对应数组下标为1,在其上加上刚刚算得的日期间隔,如200天,那么取的目标日期的下标1+200=201,又由于星期是以7为周期循环的,用7对其去模(即求余数),来计算其真正的下标(若为负数,则还要保证该下标为正,可以简单的处理成余数加7再求模),201 % 7 = 5,则表示经过若干个循环后,目标天的周名下标为5。将该下标对应的星期名输出,即为需要的答案,weekName[5],“Friday”即为所求。
由此可总结出处理区间问题的一种重要方法——预处理。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值