poj 1408 Fishnet

Fishnet
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2212 Accepted: 1396

Description

A fisherman named Etadokah awoke in a very small island. He could see calm, beautiful and blue sea around the island. The previous night he had encountered a terrible storm and had reached this uninhabited island. Some wrecks of his ship were spread around him. He found a square wood-frame and a long thread among the wrecks. He had to survive in this island until someone came and saved him. 

In order to catch fish, he began to make a kind of fishnet by cutting the long thread into short threads and fixing them at pegs on the square wood-frame. He wanted to know the sizes of the meshes of the fishnet to see whether he could catch small fish as well as large ones. 

The wood frame is perfectly square with four thin edges on meter long: a bottom edge, a top edge, a left edge, and a right edge. There are n pegs on each edge, and thus there are 4n pegs in total. The positions of pegs are represented by their (x,y)-coordinates. Those of an example case with n=2 are depicted in figures below. The position of the ith peg on the bottom edge is represented by (ai,0). That on the top edge, on the left edge and on the right edge are represented by (bi,1), (0,ci) and (1,di), respectively. The long thread is cut into 2n threads with appropriate lengths. The threads are strained between (ai,0) and (bi,1),and between (0,ci) and (1,di) (i=1,...,n). 

You should write a program that reports the size of the largest mesh among the (n+1)2 meshes of the fishnet made by fixing the threads at the pegs. You may assume that the thread he found is long enough to make the fishnet and the wood-frame is thin enough for neglecting its thickness. 
 

Input

The input consists of multiple sub-problems followed by a line containing a zero that indicates the end of input. Each sub-problem is given in the following format. 

a1 a2 ... an 
b1 b2 ... bn 
c1 c2 ... cn 
d1 d2 ... dn 
you may assume 0 < n <= 30, 0 < ai,bi,ci,di < 1

Output

For each sub-problem, the size of the largest mesh should be printed followed by a new line. Each value should be represented by 6 digits after the decimal point, and it may not have an error greater than 0.000001.

Sample Input

2
0.2000000 0.6000000
0.3000000 0.8000000
0.1000000 0.5000000
0.5000000 0.6000000
2
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
4
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
2
0.5138701 0.9476283
0.1717362 0.1757412
0.3086521 0.7022313
0.2264312 0.5345343
1
0.4000000
0.6000000
0.3000000
0.5000000
0

Sample Output

0.215657
0.111112
0.078923
0.279223
0.348958

Source


挺水的题,不过还是错了两遍,因为感觉自己没玩过这么多代码的,思路大体就是先用数组求出来所有交点,因为要找最大的网格吧,也或者是因为这里是渔网,所以得是对应(去图上试着理解下)连接,所以交点就好求了,然后用三角形求面积的公式去求面积及就好了,最后比较一下,找出最大的值,就完了。对了,要注意去给那个保存点的数组初始化一下,边界点付成零或一。然后就可以的,注意,一定得仔细。输出的小数点控制在六位%.6lf
ac代码:
#include <stdio.h>
#include <math.h>
struct node
{
	double x,y;
}point[35][35];
double max(double x,double y)
{
	return x>y?x:y;
}
double xmult(node a,node b,node c)
{//向量乘法求面积,返回 
	return (a.x-c.x)*(b.y-c.y)-(b.x-c.x)*(a.y-c.y);
}
void init(int n)
{//初始化保存点的数组 
	point[0][0].x=0.0;
	point[0][0].y=0.0;
	point[0][n+1].x=1.0;
	point[0][n+1].y=0.0;
	point[n+1][0].x=0.0;
	point[n+1][0].y=1.0;
	point[n+1][n+1].x=1.0;
	point[n+1][n+1].y=1.0;
}
node intersection(node a,node b ,node c, node d)        
{  //求交点 ,公式自己推 
    node tmp=a;  
    double t=((a.x-c.x)*(c.y-d.y)-(a.y-c.y)*(c.x-d.x))/((a.x-b.x)*(c.y-d.y)-(a.y-b.y)*(c.x-d.x));  
    tmp.x+=(b.x-a.x)*t;  
    tmp.y+=(b.y-a.y)*t;  
    return tmp;  
}  

int main()
{
	int n,i,j;
	double maxarea,tmp;
	while(~scanf("%d",&n),n)
	{
		init(n);
		maxarea=0.0;
		
		for(i=1;i<=n;i++)
		{//上边那行,补全剩余坐标值 
			scanf("%lf",&point[0][i].x);
			point[0][i].y=0;
		}
		for(i=1; i<=n; i++)  
        {//下边那行 补全剩余坐标值
            scanf("%lf",&point[n+1][i].x);  
            point[n+1][i].y=1;  
        }  
        for(i=1; i<=n; i++)  
        {//左边 补全剩余坐标值
            scanf("%lf",&point[i][0].y);  
            point[i][0].x=0;  
        }  
        for(i=1; i<=n; i++)  
        {//右边 补全剩余坐标值
            scanf("%lf",&point[i][n+1].y);  
            point[i][n+1].x=1.0;  
        }  
        for(j=1; j<=n; j++)  
        {  
            for(i=1; i<=n; i++)  
            {  //求出交点,想了想如果想出最大,那一定得是对应的位置 
                point[i][j]=intersection(point[0][j],point[n+1][j],point[i][0],point[i][n+1]);  
            }  
        }  
        for(i=1; i<=n+1; i++)  
        {  
            for(j=1; j<=n+1; j++) 
            { //组成面积的两个三角形可能不一样 
                tmp=fabs(xmult(point[i-1][j-1],point[i][j],point[i][j-1]));  
                tmp+=fabs(xmult(point[i-1][j-1],point[i][j],point[i-1][j]));  
                tmp/=2;  
                if(maxarea < tmp)  
                    maxarea = tmp;  
            }  
        }  
        printf("%.6f\n",maxarea);  
    }  
    return 0;  
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值