POJ 2431 Expedition (贪心+优先队列)

Expedition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14945 Accepted: 4188

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

题意:一辆卡车需要从一个地方地去往一个town,初始有p单位的油,town在距离起点L处的地方,途中有N个加油站,对每个加油站,给出两个数据,距离终点town的距离,以及最大可加油量,问你是否能到达终点,如果能到达终点,最少需要进入几个加油站加油。

思路:我们需要进入最少的加油站,这说明我们要用贪心算法的思想,尽量去油量最大的加油站加油,而不是路过一个加油站便加油。我们可以这样想,在经过第i个加油站时,我们就有了加fuel[i].val的权利,把这个油量存入优先队列,当我们无法到达下一个加油站或终点时,便从优先队列中取出最大的,加油。代码中用了一些小技巧,注释有写。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<queue>
#include<algorithm> 
using namespace std;
struct node{//加油站 
	int dis;
	int val;
}fuel[10005];
bool cmp(node n1, node n2){
	return n1.dis < n2.dis;
}
int main(){
	int p, n, l, ans, i, now;
	while(scanf("%d", &n) != EOF){
		ans = 0;
		now = 0;
		priority_queue<int> q;	
		for(i = n - 1; i >= 0; i--){
			scanf("%d%d", &fuel[i].dis, &fuel[i].val);
		}
		scanf("%d%d", &l, &p);
		for(i = 0; i < n; i++){//转化为距离起点的路程,这样方便计算。 
			fuel[i].dis = l - fuel[i].dis;
		}
		sort(fuel, fuel + n, cmp);//给出的加油站并不是按距离顺序的,所以需要排序 
		fuel[n].dis = l;//把终点当成最后一个加油站 
		fuel[n].val = 0;
		for(i = 0; i <= n; i++){//要经过所有加油站,才能到终点(假想的最后一个加油站) 
			int d = fuel[i].dis - now;//到下一个加油站还需要开的距离 
			while(p < d){//如果油箱中的油不够 
				if(q.empty()){//若队列为空,即无法到达下一个加油站,就无法到达终点 
					cout<<-1<<endl;
					return 0;
				}
				p += q.top();
				q.pop();
				ans++;
			}
			p -= d; 
			now = fuel[i].dis;//到达此加油站 
			q.push(fuel[i].val);//将此加油站的油量放入优先队列	
		}
		cout<<ans<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值