MG loves gold
Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)Total Submission(s): 131 Accepted Submission(s): 80
Problem Description
MG is a lucky boy. He is always be able to find gold from underground.
It is known that the gold is a sequence with n elements, which has its own color C .
MG can dig out a continuous area of sequence every time by using one shovel, but he's unwilling to dig the golds of the same color with one shovel.
As a greedy person, he wish to take all the n golds away with least shovel.
The rules also require MG not to dig twice at the same position.
MG thought it very easy and he had himself disdained to take the job. As a bystander, could you please help settle the problem and calculate the answer?
It is known that the gold is a sequence with n elements, which has its own color C .
MG can dig out a continuous area of sequence every time by using one shovel, but he's unwilling to dig the golds of the same color with one shovel.
As a greedy person, he wish to take all the n golds away with least shovel.
The rules also require MG not to dig twice at the same position.
MG thought it very easy and he had himself disdained to take the job. As a bystander, could you please help settle the problem and calculate the answer?
Input
The first line is an integer
T
which indicates the case number.(
1<=T<=10
)
And as for each case, there are 1 integer n in the first line which indicate gold-number( 1<=n<=100000 ).
Then there are n integers C in the next line, the x-th integer means the x-th gold’s color( |C|<=2000000000 ).
And as for each case, there are 1 integer n in the first line which indicate gold-number( 1<=n<=100000 ).
Then there are n integers C in the next line, the x-th integer means the x-th gold’s color( |C|<=2000000000 ).
Output
As for each case, you need to output a single line.
there should be one integer in the line which represents the least possible number of shovels after taking away all n golds.
there should be one integer in the line which represents the least possible number of shovels after taking away all n golds.
Sample Input
2 5 1 1 2 3 -1 5 1 1 2 2 3
Sample Output
2 3
思路:给出一个数字序列,求最少能分成多少个连续的不包含相同数字的子序列。因为数据范围较大,需要用map。
#include<cstdio>
#include<iostream>
#include<cstring>
#include<map>
using namespace std;
int a[100005];
map<int, int> mp;
int main(){
int cases, i, j, n, cnt;
cin>>cases;
while(cases--){
cin>>n;
cnt = 1;
mp.clear();
for(i = 0; i < n; i++){
scanf("%d", &a[i]);
if(mp[a[i]]){
cnt++;
mp.clear();
mp[a[i]] = 1;
}
mp[a[i]] = 1;
}
cout<<cnt<<endl;
}
return 0;
}