poj 3268 Silver Cow Party 最短路

题目链接:点击打开链接

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 26082 Accepted: 11917

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.


题意:给你n个点,m条单向边,位置x,求的是所有点到x并回到自身的距离的最短距离的最大值,但是限制条件是

一条路不能走两遍。

题解:迪杰斯特拉分别跑位置i到x,x到i的最短路径,但是跑的时候要注意记录路径,跑完的时候对路径的点进行标记,

标记为已访问。最后统计最大值。

AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>

using namespace std;

const int maxn = 1010;
const int INF = 0x3f3f3f3f;

typedef pair <int,int> P;
int n,m,x;
vector <P> E[maxn];
long long d[maxn];
bool vis[maxn][maxn];
int pre[maxn];

int dj(int s,int e)
{
    priority_queue <P> que;
    que.push(P(-d[s],s));
    d[s]=0;
    pre[s]=0;
    while(!que.empty())
    {
        int now=que.top().second;
        que.pop();
        for(int i=0;i<E[now].size();i++)
        {
            int v=E[now][i].first;
            if(d[v]>d[now]+E[now][i].second&&!vis[now][i])
            {
                d[v]=d[now]+E[now][i].second;
                pre[v]=now;
                que.push(P(-d[v],v));
            }
        }
    }
    int root=pre[e];
    while(root!=0)
    {
        int tmp=pre[root];
        vis[tmp][root]=true;
        root=tmp;
    }
    return d[e];
}

int main()
{
    scanf("%d%d%d",&n,&m,&x);
    int u,v,w;
    for(int i=1;i<=m;i++)
    {
        scanf("%d%d%d",&u,&v,&w);
        E[u].push_back(P(v,w));
    }
    memset(dis,0,sizeof(dis));
    long long ans=0;
    for(int i=1;i<=n;i++)
    {
        if(i==x) continue;
        long long tmp=0;
        memset(vis,false,sizeof(vis));
        memset(d,INF,sizeof(d));
        tmp+=dj(i,x);
        memset(d,INF,sizeof(d));
        tmp+=dj(x,i);
        ans=max(ans,tmp);
    }
    printf("%lld\n",ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值