poj3126 bfs

Prime Path
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7744   Accepted: 4407

Description

poj <wbr>3126 <wbr>广度搜索The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3 1033 8179 1373 8017 1033 1033

Sample Output

6 7 0

Source

解题代码:
#include <iostream>
#include <stdio.h>
#include<math.h>
#include <queue>
using namespace std;
int ge;
int shi;
int bai;
int qian;
int record[10000];
int start;
int last;
queue<int> p;
int current;
int assemble()
{
	return ge+shi*10+bai*100+qian*1000;
}
bool JudgePrime(int a)
{
	int i;
	for(i=2;i<=(int)sqrt(a)+1;i++)
		if (a%i==0)
		{
			return false;
		}
	return true;
}
void bfs()
{
	if (start==last)
	{
		record[last]=0;
		cout<<0<<endl;return;
	}
	current=start;
    while(true)
	{
		ge=current%10;int l=ge;
		shi=(current/10)%10;int k=shi;
		bai=(current/100)%10;int j=bai;
		qian=(current/1000)%10;int i=qian;
		bool find=false;
		for(qian=1;qian<10;qian++)
		{
			if(qian!=i)
			{
			int next=assemble();
			
			if(JudgePrime(next)==true)
			{
				if (next==last)
			  {
				find=true;
				record[last]=record[current]+1;
				cout<<record[last]<<endl;
				return;
			   }
				if(record[next]==0)
				{
				p.push(next);
				record[next]=record[current]+1;
				}
			}
			}
		}
		qian=i;
		for(bai=0;bai<10;bai++)
		{
			if(bai!=j)
			{int next=assemble();
			
			if(JudgePrime(next)==true)
			{
				if (next==last)
			  {
				find=true;
				record[last]=record[current]+1;
				cout<<record[last]<<endl;
				return;
			   }
				if(record[next]==0)
				{
				p.push(next);
				record[next]=record[current]+1;
				}
			}
			}
		}
		bai=j;
		for(shi=0;shi<10;shi++)
		{
			if(shi!=k)
			{
			int next=assemble();
			
			if(JudgePrime(next)==true)
			{
				if (next==last)
			  {
				find=true;
				record[last]=record[current]+1;
				cout<<record[last]<<endl;
				return;
			   }
				if(record[next]==0)
				{
				p.push(next);
				record[next]=record[current]+1;
				}
			}
			}
		}
		shi=k;
		for(ge=1;ge<10;ge++)
		{
			if(ge!=l)
			{
			int next=assemble();
			
			if(JudgePrime(next)==true)
			{
				if (next==last)
			  {
				find=true;
				record[last]=record[current]+1;
				cout<<record[last]<<endl;
				return;
			   }
				if(record[next]==0)
				{
				p.push(next);
				record[next]=record[current]+1;
				}
			}
			}
		}
		
		if(p.empty())break;
		current=p.front();
		p.pop();

	}
	if(record[last]==0)cout<<"Impossible"<<endl;
}
int main()
{
	int n,i;
	cin>>n;
	for(i=1;i<=n;i++)
	{
		int j;
		for(j=1001;j<=9999;j++)record[j]=0;
		while(!p.empty())
		{
			p.pop();
		}
	cin>>start>>last;
	bfs();
	
	
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值