Ultra-QuickSort (树状数组)

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 

9 1 0 5 4 ,


Ultra-QuickSort produces the output 

0 1 4 5 9 .


Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

思路

这道题用到了树状数组的思想。这道题是求给出一串数组把他按小到大排序,需要交换的次数。

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
#define ll long long

using namespace std;
int n;
int b[500005];
struct node
{
    int x;
    int num;
}a[500005];

int lowbit(int t)
{
    return t&(-t);
}//取出t的最低位1

int sum(int x)//区间查询
{
    int ans=0;
    for(int i=x;i>0;i-=lowbit(i))
        ans+=b[i];
    return ans;
}

void update(int x,int y)//单点更新
{
    for(int i=x;i<=n;i+=lowbit(i))
        b[i]+=y;
}

bool cmp1(node a,node b)
{
    return a.x<b.x;
}

bool cmp2(node a,node b)
{
    return a.num<b.num;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i].x);
            a[i].num=i;
        }
        sort(a+1,a+1+n,cmp1);
        for(int i=1;i<=n;i++)
        {
            a[i].x=i;
        }
        sort(a+1,a+1+n,cmp2);
        memset(b,0,sizeof(b));
        long long ans=0;
        for(int i=1;i<=n;i++)
        {
            ans=ans+i-sum(a[i].x)-1;
            update(a[i].x,1);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值