Wormholes (最短路)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

思路

这道题用到了最短路的思想。这道题的有一些特殊的要求,就是他的道路是单向的,并不是双向的。所以在写代码的时候,要稍微注意一下。

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <queue>

using namespace std;
int n,m,w,F;
int s,e,t;
int head[6000];//head表示邻接表的头点
int vis[610],tim[610],dis[610];//dis表示从起点到i的当前距离,vis表示遍历这个点的次数
const int inf=0x3f3f3f3f;

struct node//邻接表存图
{
    int v,nt;
    int w;
}edge[6000];

int cnt=0;
void add(int u,int v,int w)
{
    edge[cnt].nt=head[u];
    edge[cnt].v=v;
    edge[cnt].w=w;
    head[u]=cnt++;
}

int spfa(int st)
{
    int now;
    memset(vis,0,sizeof(vis));
    memset(tim,0,sizeof(tim));
    memset(dis,inf,sizeof(dis));
    vis[st]=1,dis[st]=0,tim[st]=1;
    queue<int> q;
    q.push(st);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        vis[now]=0;
        for(int i=head[now];i!=-1;i=edge[i].nt)//计算最短路径(包含出现负数)
        {
            int v=edge[i].v,w=edge[i].w;
            if(dis[v]>dis[now]+w)
            {
                dis[v]=dis[now]+w;
                if(!vis[v])
                {
                    q.push(v);
                    vis[v]=1,tim[v]++;
                    if(tim[v]>=n)//如果v点遍历过了,就返回1
                        return 1;
                }
            }
        }
    }
    return 0;
}

int main()
{
    scanf("%d",&F);
    while(F--)
    {
        cnt=0;
        memset(head,-1,sizeof(head));
        scanf("%d %d %d",&n,&m,&w);
        for(int i=1;i<=m;i++)
        {
            scanf("%d %d %d",&s,&e,&t);
            add(s,e,t);
            add(e,s,t);
        }
        for(int i=1;i<=w;i++)
        {
            scanf("%d %d %d",&s,&e,&t);
            t=t*(-1);
            add(s,e,t);
        }
        int flag=0;
        for(int i=1;i<=n;i++)
        {
            if(spfa(i))
            {
                flag=1;
                break;
            }
        }
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值