Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
搜索题;
好像又是种子填充;
难度不高;
#include<iostream>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<stack>
#include<queue>
#include<iomanip>
#include<map>
#define pi 3.14159265358979323846
using namespace std;
struct point
{
int x,y;
};
point start;
int W,H;
char maze[25][25];
int dx[]={1,-1,0,0};
int dy[]={0,0,1,-1};
int ans;
bool flag[25][25];
void dfs(int x,int y)
{
flag[x][y]=1;
point temp;
for(int i=0;i<4;++i)
{
temp.x=x+dx[i];
temp.y=y+dy[i];
if(temp.x>=0&&temp.x<H&&temp.y>=0&&temp.y<W&&flag[temp.x][temp.y]==0&&maze[temp.x][temp.y]=='.')
{
++ans;
dfs(temp.x,temp.y);
}
}
}
int main()
{
while(scanf("%d %d",&W,&H)!=EOF&&W&&H)
{
for(int i=0;i<H;++i)
for(int j=0;j<W;++j)
{
scanf(" %c",&maze[i][j]);
if(maze[i][j]=='@')
{
start.x=i;
start.y=j;
}
}
ans=1;
memset(flag,0,sizeof(flag));
dfs(start.x,start.y);
printf("%d\n",ans);
}
return 0;
}