hdu 1394 Minimum Inversion Number

Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
我采用线段树解决此问题;
每插入一个结点,就检查之前是否有更大的数插入,以此统计逆序对;
注意到数字是0到n的一个序列,所以每次将队头的数字移到队尾,逆序对的增减可以找出递推式;
#include<iostream>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<stack>
#include<queue>
#include<iomanip>
#include<map>
#define pi 3.14159265358979323846
using namespace std;
int s[5001];
int tree[20001];
void build(int p,int l,int r)
{
    if(l==r) {tree[p]=0;return;}
    int mid=(l+r)/2;
    build(p*2,l,mid);
    build(p*2+1,mid+1,r);
    tree[p]=0;
}
void change(int p,int l,int r,int x,int num)
{
    if(l==r) {tree[p]+=num;return;}
    int mid=(l+r)/2;
    if(x<=mid) change(p*2,l,mid,x,num);
    else change(p*2+1,mid+1,r,x,num);
    tree[p]=tree[p*2]+tree[p*2+1];
}
int find(int p,int l,int r,int x,int y)
{
    if(x<=l&&r<=y) return tree[p];
    int mid=(l+r)/2;
    if(y<=mid) return find(p*2,l,mid,x,y);
    if(x>mid) return find(p*2+1,mid+1,r,x,y);
    return (find(p*2,l,mid,x,mid)+find(p*2+1,mid+1,r,mid+1,y));
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        build(1,1,5000);
        int ans=0;
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&s[i]);
            ans+=find(1,1,5000,s[i]+1,5000);//统计逆序对
            change(1,1,5000,s[i]+1,1);
        }
        int smin=ans;
        for(int i=1;i<=n;++i)
        {
            ans=ans+n-2*s[i]-1;//递推式
            if(ans<smin)
                smin=ans;
        }
        printf("%d\n",smin);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值