现在需要统计若干段文字(英文)中的单词数量,并且还需统计每个单词出现的次数。
注1:单词之间以空格(1个或多个空格)为间隔。
注2:忽略空行或者空格行。
基本版:
统计时,区分字母大小写,且不删除指定标点符号。
进阶版:
统计前,需要从文字中删除指定标点符号!.,😗?。 注意:所谓的删除,就是用1个空格替换掉相应字符。
统计单词时需要忽略单词的大小写。
###输入说明 若干行英文,最后以!!!为结束。
###输出说明 单词数量
出现次数排名前10的单词(次数按照降序排序,如果次数相同,则按照键值的字母升序排序)及出现次数。
输入样例1
failure is probably the fortification in your pole
it is like a peek your wallet as the thief when you
are thinking how to spend several hard-won lepta
when you are wondering whether new money it has laid
background because of you then at the heart of the
most lax alert and most low awareness and left it
godsend failed
!!!!!
输出样例1
46
the=4
it=3
you=3
and=2
are=2
is=2
most=2
of=2
when=2
your=2
输入样例2
Failure is probably The fortification in your pole!
It is like a peek your wallet as the thief when You
are thinking how to. spend several hard-won lepta.
when yoU are? wondering whether new money it has laid
background Because of: yOu?, then at the heart of the
Tom say: Who is the best? No one dare to say yes.
most lax alert and! most low awareness and* left it
godsend failed
!!!!!
输出样例2
54
the=5
is=3
it=3
you=3
and=2
are=2
most=2
of=2
say=2
to=2
import java.util.*;
import java.lang.*;
public class Main {
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
Map<String, Integer> m = new HashMap<>();
int word_num=0;
while (true) {
String str = in.next();
str=str.toLowerCase();
if (str.equals("!!!!!")) break;
str=str.replaceAll("[!.,:*?]", "");
if (m.containsKey(str)) {
int v = m.get(str) + 1;
m.put(str, v);
} else {
m.put(str, 1);
word_num++;
}
}
List<Map.Entry<String, Integer>> list = new LinkedList<Map.Entry<String, Integer>>(m.entrySet());
list.sort((o1, o2) -> {
if (o1.getValue().compareTo(o2.getValue()) < 0)
return 1;
else if (o1.getValue().compareTo(o2.getValue()) > 0)
return -1;
else {
return o1.getKey().compareTo(o2.getKey());
}
});
Map<String,Integer> map = new LinkedHashMap<String ,Integer>();
for(Map.Entry<String,Integer> entry:list)
{
map.put(entry.getKey(),entry.getValue());
}
System.out.println(word_num);
int count = 0;
for (Map.Entry<String, Integer> entry : map.entrySet()) {
count++;
System.out.println(entry.getKey()+" "+entry.getValue());
if(count==10)break;
}
}
}