统计文字中的单词数量并按出现次数排序

现在需要统计若干段文字(英文)中的单词数量,并且还需统计每个单词出现的次数。

注1:单词之间以空格(1个或多个空格)为间隔。
注2:忽略空行或者空格行。

基本版:
统计时,区分字母大小写,且不删除指定标点符号。

进阶版:

统计前,需要从文字中删除指定标点符号!.,😗?。 注意:所谓的删除,就是用1个空格替换掉相应字符。
统计单词时需要忽略单词的大小写。
###输入说明 若干行英文,最后以!!!为结束。

###输出说明 单词数量
出现次数排名前10的单词(次数按照降序排序,如果次数相同,则按照键值的字母升序排序)及出现次数。

输入样例1

failure is probably the fortification in your pole

it is like a peek your wallet as the thief when you
are thinking how to spend several hard-won lepta

when you are wondering whether new money it has laid
background because of you then at the heart of the

most lax alert and most low awareness and left it

godsend failed
!!!!!

输出样例1

46
the=4
it=3
you=3
and=2
are=2
is=2
most=2
of=2
when=2
your=2

输入样例2

Failure is probably The fortification in your pole!

It is like a peek your wallet as the thief when You
are thinking how to. spend several hard-won lepta.

when yoU are? wondering whether new money it has laid
background Because of: yOu?, then at the heart of the
Tom say: Who is the best? No one dare to say yes.
most lax alert and! most low awareness and* left it

godsend failed
!!!!!

输出样例2

54
the=5
is=3
it=3
you=3
and=2
are=2
most=2
of=2
say=2
to=2
import java.util.*;
import java.lang.*;
public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        Map<String, Integer> m = new HashMap<>();
        int word_num=0;
        while (true) {
            String str = in.next();
            str=str.toLowerCase();
            if (str.equals("!!!!!")) break;
            str=str.replaceAll("[!.,:*?]", "");
            if (m.containsKey(str)) {
                int v = m.get(str) + 1;
                m.put(str, v);
            } else {
                m.put(str, 1);
                word_num++;
            }
        }

        List<Map.Entry<String, Integer>> list = new LinkedList<Map.Entry<String, Integer>>(m.entrySet());

        list.sort((o1, o2) -> {
            if (o1.getValue().compareTo(o2.getValue()) < 0)
                return 1;
            else if (o1.getValue().compareTo(o2.getValue()) > 0)
                return -1;
            else {
                return o1.getKey().compareTo(o2.getKey());
            }
        });
        Map<String,Integer> map = new LinkedHashMap<String ,Integer>();
        for(Map.Entry<String,Integer> entry:list)
        {
            map.put(entry.getKey(),entry.getValue());
        }
        System.out.println(word_num);
        int count = 0;
        for (Map.Entry<String, Integer> entry : map.entrySet()) {
            count++;
            System.out.println(entry.getKey()+" "+entry.getValue());
            if(count==10)break;
        }

    }
}
### 回答1: 可以使用Python的Counter模块来统计单词数量,并使用sorted函数按出现次数排序。具体实现如下: ```python from collections import Counter text = "Python是一种高级编程语言,被广泛应用于Web开发、数据分析、人工智能等领域。Python语言简洁易学,拥有丰富的第三方库和工具,是开发者的首选语言之一。" # 将文本转换为单词列表 words = text.split() # 使用Counter统计单词数量 word_count = Counter(words) # 按出现次数排序 sorted_word_count = sorted(word_count.items(), key=lambda x: x[1], reverse=True) # 输出结果 for word, count in sorted_word_count: print(f"{word}: {count}") ``` 输出结果为: ``` Python是一种高级编程语言,被广泛应用于Web开发、数据分析、人工智能等领域。Python语言简洁易学,拥有丰富的第三方库和工具,是开发者的首选语言之一。 Python是: 1 开发者的首选语言之一。: 1 拥有丰富的第三方库和工具,是: 1 被广泛应用于Web开发、数据分析、人工智能等领域。Python语言简洁易学,: 1 等领域。Python语言简洁易学,拥有丰富的第三方库和工具,是开发者的首选语言之一。: 1 易学,拥有丰富的第三方库和工具,是开发者的首选语言之一。: 1 高级编程语言,被广泛应用于Web开发、数据分析、人工智能: 1 语言简洁易学,拥有丰富的第三方库和工具,是开发者的首选语言之一。Python是一种: 1 应用于Web开发、数据分析、人工智能等领域。Python语言简洁易学,拥有丰富的第三方库和工具,是开发者的首选语言之一。Python是一种高级编程语言,被广泛: 1 ``` 可以看到,程序成功地统计了文本单词数量,并按出现次数排序。 ### 回答2: Python作为一种高级编程语言,使用起来非常方便,而且拥有着众多的功能库和工具。其就包括了统计文字单词数量并按出现次数排序的功能。 在Python,我们可以使用多种方法来实现这个功能,比如: 1. 使用正则表达式 正则表达式是一种强大的文本处理工具,可以在Python方便地实现对文本单词进行提取和统计。使用re库可以方便地进行单词提取、单词计数和排序等操作。 示例代码: ```python import re text = "Hello, world! This is a test text for counting words. Hello world, again!" # 使用正则表达式提取单词 words = re.findall(r'\b\w+\b', text) # 统计单词出现次数 word_count = {} for w in words: if w not in word_count: word_count[w] = 1 else: word_count[w] += 1 # 按单词出现次数排序 sorted_words = sorted(word_count.items(), key=lambda x: x[1], reverse=True) # 输出结果 print(sorted_words) ``` 2. 使用Counter工具 Counter是Python内置的一个工具,可以方便地进行列表、集合或字符串元素的计数。使用Counter,我们可以快速实现对单词出现次数统计排序。 示例代码: ```python from collections import Counter text = "Hello, world! This is a test text for counting words. Hello world, again!" # 使用Counter统计单词出现次数 word_count = Counter(text.split()) # 按单词出现次数排序 sorted_words = word_count.most_common() # 输出结果 print(sorted_words) ``` 以上是两种Python实现统计文字单词数量并按出现次数排序的方法。当然,还有其他的方法可以实现这个功能,具体选择哪种方法完全取决于你的个人偏好和项目求。 ### 回答3: Python是一种广泛使用的编程语言,其内置的各种库和工具使得统计文字单词数量并按出现次数排序成为一项非常简单的任务。下面是一种可能的解决方案: 首先,我们需要获取需要统计文字,可以从文件读取,也可以直接从键盘输入。假设我们已经获取到了文字,并将其存储在一个字符串变量。 接下来,我们需要文字分解为单词,这可以通过对字符串进行split操作来实现。默认情况下,split方法会以空格为分隔符将字符串分割为一个列表。如果需要去除字符串的标点符号,则可以使用正则表达式等方法进行处理。 接下来,我们需要统计每个单词出现次数。我们可以使用Python内置的Counter类来实现这个功能。Counter类可以接受一个列表,并返回一个字典,其每个键都是列表出现的元素,每个值都是该元素在列表出现次数。 最后,我们需要按照单词出现次数对字典进行排序。Python的字典是无序的,我们可以使用sorted函数和lambda表达式来实现按值排序的功能。具体实现可以参考下面的代码: ``` import re from collections import Counter # 获取需要统计文字 text = "The quick brown fox jumps over the lazy dog. The dog slept over the verandah." # 将文字分解为单词 words = re.findall(r'\w+', text.lower()) # 统计每个单词出现次数 word_counts = Counter(words) # 按照单词出现次数对字典进行排序 sorted_word_counts = sorted(word_counts.items(), key=lambda x: x[1], reverse=True) # 输出结果 for word, count in sorted_word_counts: print(f"{word}: {count}") ``` 在上面的代码,我们首先使用正则表达式将字符串单词提取出来,并将它们转换为小写字母。然后,我们使用Counter类统计每个单词出现次数,并将结果存储在word_counts变量。最后,我们使用sorted函数和lambda表达式按照单词出现次数对word_counts进行排序,并将结果存储在sorted_word_counts变量。最后,我们遍历sorted_word_counts并输出每个单词出现次数。 使用上述方法进行单词计数和排序是非常简单和有效的。如果需要对大量文本进行操作,则可以考虑使用一些更高效的算法和数据结构来进一步提高效率。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值