数列1

题目描述

输入

输出

样例输入

0 1
2000000000 1

样例输出

no
yes

提示



题解:

xn=axn-1+b

两边同加b/(a-1).

最终得到xn=(a^n(a+b-1)-b)/(a-1)

再进行讨论求解.



#include <cstdio>
#include <iostream>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
long long a,b;
int main()
{
    while(scanf("%lld%lld",&a,&b)!=-1)
    {
        if(a==1000000000)
        {
            if(!b)printf("no\n");
            elseprintf("yes\n");
        }
        else
        {
            if(abs(a)<=1000000000 || a+b==1000000000)printf("no\n");
            elseprintf("yes\n");
        }
    }
    return0;
} 



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值