字典树trie树 模板题 POJ2001 Shortest Prefixes

9 篇文章 0 订阅
1 篇文章 0 订阅
Shortest Prefixes
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 19565 Accepted: 8486

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

Source




题目大意:给定不超过1000个长度不超过20的子串,找出能唯一表示每个子串的最短前缀,如果找不出,就输出该字符串。
那当然是trie树的裸题啦,睡前写一道喔。
trie树,就是每一个节点向下发出26条边(可以不是,但这里是小写字母所以26条),这是一种存储子串的方法,也叫字典树。
这棵树中的节点有些是危险节点,即从根节点走到当前节点所经过的边上字母组成的字符串在子串中出现过。

对于此题,显而易见,如果在某一个节点往下再走只有一个危险节点了,那么这一定是最短前缀啦~


#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#include <cmath>
using namespace std;
char a[2000][100];
int cnt,n,t[300300][26],sum[300300];
void insert(char ch[]){
	int len=strlen(ch+1),now=0;
	for(int j=1;j<=len;j++){
		int k=ch[j]-'a';
		if(t[now][k]==0) t[now][k]=++cnt;
		now=t[now][k];
		sum[now]++;
	}
}
void solve(char ch[]){
	int len=strlen(ch+1),now=0;
	for(int j=1;j<=len;j++){
		if(sum[now]==1) break;
		int k=ch[j]-'a';
		printf("%c",ch[j]);
		now=t[now][k];
	}
}
int main()
{
	while(scanf("%s",a[++n]+1) != EOF) insert(a[n]);
	for(int i=1;i<=n;i++){
		printf("%s ",a[i]+1);
		solve(a[i]);
		printf("\n");
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 内容概要 《计算机试卷1》是一份综合性的计算机基础和应用测试卷,涵盖了计算机硬件、软件、操作系统、网络、多媒体技术等多个领域的知识点。试卷包括单选和操作应用两大类,单选部分测试学生对计算机基础知识的掌握,操作应用部分则评估学生对计算机应用软件的实际操作能力。 ### 适用人群 本试卷适用于: - 计算机专业或信息技术相关专业的学生,用于课程学习或考试复习。 - 准备计算机等级考试或职业资格认证的人士,作为实战演练材料。 - 对计算机操作有兴趣的自学者,用于提升个人计算机应用技能。 - 计算机基础教育工作者,作为教学资源或出参考。 ### 使用场景及目标 1. **学习评估**:作为学校或教育机构对学生计算机基础知识和应用技能的评估工具。 2. **自学测试**:供个人自学者检验自己对计算机知识的掌握程度和操作熟练度。 3. **职业发展**:帮助职场人士通过实际操作练习,提升计算机应用能力,增强工作竞争力。 4. **教学资源**:教师可以用于课堂教学,作为教学内容的补充或学生的课后练习。 5. **竞赛准备**:适合准备计算机相关竞赛的学生,作为强化训练和技能检测的材料。 试卷的目标是通过系统性的目设计,帮助学生全面复习和巩固计算机基础知识,同时通过实际操作目,提高学生解决实际问的能力。通过本试卷的学习与练习,学生将能够更加深入地理解计算机的工作原理,掌握常用软件的使用方法,为未来的学术或职业生涯打下坚实的基础。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值