Codeup100000587问题 A: 求第k大数

Codeup100000587问题 A: 求第k大数

题目描述:

给定一个长度为n(1≤n≤1,000,000)的无序正整数序列,以及另一个数k(1≤k≤1,000,000)(关于第k大的数:例如序列{1,2,3,4,5,6}中第3大的数是4。)

输入:

第一行两个正整数m,n。

第二行为n个正整数。

输出:

第k大的数。

样例输入:

6 3
1 2 3 4 5 6

样例输出:

4

实现代码:

#include <cstdio>
#include <cstdlib>
#include <ctime>
#include <cstring>
#include <algorithm>
#include <math.h>
using namespace std;

int randPartition(int A[],int left,int right){
	int p=round(1.0*rand()/RAND_MAX*(right-left)+left);
	swap(A[left],A[p]);
	int temp=A[left];
	while(left<right){
		while(left<right&&A[right]<temp){
			right--;
		}
		A[left]=A[right];
		while(left<right&&A[left]>temp){
			left++;
		}
		A[right]=A[left];
	}
	A[left]=temp;
	return left;
}

int randSelect(int A[],int left,int right,int K){
	if(left==right){
		return A[left];
	}
	int p=randPartition(A,left,right);
	int M=p-left+1;
	if(M==K){
		return A[p];
	}else if(K<M){
		return randSelect(A,left,p-1,K);
	}else{
		return randSelect(A,p+1,right,K-M);
	}
	
}

int main()
{
	int m,n;
	int num[100010];
	srand((unsigned)time(NULL));
	while(scanf("%d%d",&m,&n)!=EOF){
		for(int i=0;i<m;i++){
			scanf("%d",&num[i]);
		}
		int ans=randSelect(num,0,m-1,n);
		printf("%d\n",ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值