Py||Integer

题目描述
Give an integer of no more than 5 digits.

Requires:

  1. Find out how many digits it is.
  2. Output each digit separately.
  3. Output each digit in reverse order.
    For example, the original number is 321 and should output 123.
    输入
    a number no larger than 5 digits.
    输出
    Three lines:

First line, number of digits
Second line, each number separated by a space, note that there is no space after the last number.
Third line, output this number in reverse order
样例输入 Copy
12345
样例输出 Copy
5
1 2 3 4 5
54321
提示
number to string

n=input()
print(len(str(n)))
for i in n:
    print(i,end=' ')
print()
print(n[::-1])

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值