Py||Perfect number

题目描述
If a number is exactly equal to the sum of its factors, this number is called the “Perfect number.”

For example, the factor of 6 is 1, 2, 3, and 6 = 1 + 2 + 3, so 6 is a “perfect number”.

Write a program to find all the perfect number within {1,2,3…N} (N is given from the input) and output their factors in the following format:

6 its factors are 1 2 3
输入
N
输出
? its factors are ? ? ?
样例输入 Copy
1000
样例输出 Copy
6 its factors are 1 2 3
28 its factors are 1 2 4 7 14
496 its factors are 1 2 4 8 16 31 62 124 248

n=int(input())
s=0
for i in range(1,n+1):
    s=0
    s1=[]
    for j in range(1,i//2+1):
        if(i%j==0):
            s=s+j
            s1.append(j)
    if s==i:
        print('%d its factors are'%i,end=' ')
        for each in s1:
            print(each,end=' ')
        print()
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值