PAT (Advanced Level) Practice 1031 Hello World for U (20)

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1

  • n2 + n3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

题意:

即左侧包含的字符数n1 = 右侧包含的字符数n2 。

最底下的字符数要尽可能的大于两边的,所以我的思路是能均分的时候均分,不能均分的时候两边比最底下少一,

采用了直接输出的方式,代码如下:

C++:

#include<cstdio>
#include<cstring>
int main(){
	char s[100] ;
	scanf("%s",&s);
	int N = strlen(s);
	
	// n1 = n3
	// n1 + n2 + n3 = N + 2
	// n1 <= n2
	// 3 <= n2 <=N
	
	for(int i=0;i<(N+2)/3-1;i++){
		printf("%c",s[i]);
		for(int j=(N+2)/3-1;j<N-((N+2)/3-1)-2;j++){
			printf(" ");
		}
		printf("%c\n",s[N-i-1]);
	}
	for(int i=(N+2)/3-1;i<N-((N+2)/3-1);i++){
		printf("%c",s[i]);
	}
	
	return 0;
} 

注:

打印空格个数采用for循环控制

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值